Conflicting "out of date" vs "up to date" statuses


#1

At the top of the Admin screen, I am told Your Discourse installation is out of date. Click here to upgrade. But when I click, each item is Up to date.

Also on the Admin screen: A check for updates has not been performed lately. Ensure sidekiq is running. However, in the Processes list, I see sidekiq 4.0.1 discourse [0 of 5 busy].

What’s going on here? I suspected that Discourse was running out of memory on my Linode 2048 because it was using swap. (Perhaps this is why sidekiq wasn’t up?) So, I just finished upgrading it to a 4096 MB instance. Now no swap is being used, but I am still unable to upgrade.

Is this something to worry about or should I just leave it be? Thanks in advance!!

(I tried to include a second screenshot, but new users can only put one image in a post, so just trust me that my Discourse install says all upgradeable items are Up to date.)


Jobs::HandledExceptionWrapper: Wrapped SocketError: getaddrinfo: Name or service not known
Jobs::HandledExceptionWrapper: Wrapped SocketError: getaddrinfo: Name or service not known
(Jeff Atwood) #2

Have you tried rebooting?


#3

Jeff, thanks for your response.

The Linode VPS rebooted when I resized it to a 4096 MB instance. I am assuming this is what you mean?

Btw I checked the admin screen again just now, thinking the situation may have corrected itself overnight due to the new extra 2 GB of RAM. However, I am still seeing the same symptoms.


(Felix Freiberger) #4

Try to visit /sidekiq – do you see Sidekiq’s dashboard there? If so, can you post a screenshot?


#5

Hi Felix, thanks a lot. Yes, I can see the dashboard. Here it is:

Note that the high number of failed jobs is from 2 months ago, when every Jobs::UserEmail failed with Jobs::HandledExceptionWrapper: Wrapped SocketError: getaddrinfo: Name or service not known. I fixed that by doing an upgrade + restart, which is good but makes me uneasy since I don’t know how I fixed it! No jobs have failed since then.


(Kane York) #6

What’s with the “9,999 Dead”? Pretty sure that’s not normal…


#7

Hi Kane, those are many failed Jobs::UserEmail from when it was messed up 2 months ago:

I do not think they are related to my current problem, but I may be wrong.


#8

/var/discourse/launcher rebuild app successfully updated Discourse for me. I am just gonna do it that way from now on.

FWIW, I suspect I have a weird Linode-specific Docker install on my Linode instance. This may or may not be the cause of my inability to update within the Discourse UI, and some other problems.


(Jeff Atwood) #9