Connection refused error after rebuilding app

I’ve just done a console rebuild of my forum, like I have many times before. I’ve done it several times now in fact. No errors are reported in the console, but the forum will not load.

https://intfiction.org/

Rebuild log:

Just came to post the same - I have a server error happening after rebuilding today. Happens without any plugins as well - I rebuilt yesterday without any issue.

Could there be an issue with the latest tests-passed?

1 Like

@gerhard Is this the same problem you just fixed?

Yes, it is. Please do another git pull and rebuild.

2 Likes

@gerhard unfortunately still not solved for me - still getting a not secure error :frowning:
Any suggestions?

You executed the following steps, right?

cd /var/discourse
git pull
./launcher rebuild app

What’s the URL of your site? Are you using Public Key Pinning or anything else that might cause problems related to TLS? Can you check your site at SSL Server Test (Powered by Qualys SSL Labs)?

1 Like

Thanks for your help @gerhard, have messaged you the test details. I’m not using Public Key Pinning as far as I know. My site is hosted on GCP and I executed the steps you described.

Oh, there seems to be a load balancer in front of your site. AFAIK the error you are seeing comes from GCP. I’m not sure how that stuff works or how you’ve configured it to work, but it might have problems with the ECDSA certificate. Are you even using the Let’s Encrypt certificate from Discourse? It looks like the load balancer is terminating the TLS connection.

3 Likes

Thanks, I am using the LE cert from Discourse. Ill try and play around and see what changes happened since the last release to make it break.