CSV export of reports fails


(Axel Naumann) #1

Clicking the the “export” button on https://[our-forum]/admin/reports/posts sends a message that it failed. I’m do not know whether it ever worked for us. I see in the error logs:

Job exception: undefined method `data' for nil:NilClass

with the backtrace:

/var/www/discourse/app/jobs/regular/export_csv_file.rb:149:in `report_export'
/var/www/discourse/app/jobs/regular/export_csv_file.rb:48:in `each'
/var/www/discourse/app/jobs/regular/export_csv_file.rb:48:in `block in execute'
/usr/local/lib/ruby/2.3.0/csv.rb:1282:in `open'
/var/www/discourse/app/jobs/regular/export_csv_file.rb:46:in `execute'
/var/www/discourse/app/jobs/base.rb:153:in `block (2 levels) in perform'

Is that a known issue? Is there something we can do to figure out a config issue on our side? Or can other people reproduce this with v1.9.0.beta11 +11?

Cheers, Axel.


Data Explorer cannot export to CSV
Exporting data-- is it possible?
(Daniela) #2

Confirmed, same error with v1.9.0.beta11 +18

(I am updating to the latest version)


(Daniela) #3

Confirmed again with the very latest version v1.9.0.beta11 +33.
The error reported in the OP is the same.


(Arpit Jalan) #5

Fixed via:

Thanks for reporting this issue @AxelN :+1:


Data Explorer cannot export to CSV
(Arpit Jalan) #6