Data Explorer cannot export to CSV


(Gergely Imreh) #1

We are using Discourse-hosted Discourse, and found that the Data Explorer plugin errors out when trying to export the results in CSV format.

We do a query, if we select “download results” in JSON it works, if in CSV, then got a HTTP 500 result…

Any idea what might be going on? Is it a known issue?


(Jeff Atwood) #2

How many rows / results are you attempting to export as CSV?


(Gergely Imreh) #3

Even with a single row we get an error (e.g. running a query with SELECT .... LIMIT 1).

I wonder if the othet CSV issue reported, CSV export of reports fails is related.


(Daniela) #4

I also believe that they are related.
Can you check the /logs page to see if you have the same error?


(Gergely Imreh) #6

Checked, and no new log shows up in the /logs when trying to do the Data Exporter. Though have tried to do the “reports” export as mentioned in the other thread, and it fails the same way (no logs then either). So definitely feels related (and that thread is probably duplicate of this one, as this was filed earlier).


(Joshua Rosenfeld) #7

Looks like @techAPJ resolved this. Try updating to latest and retest?


(Jay Pfaffman) #8

Has it been pushed yet?


(Joshua Rosenfeld) #9

It has now. Apologies, @imrehg, I glossed over that we hosted you.


(Jay Pfaffman) #10

Proof that you’re trying to help everyone, not just customers!


(Gergely Imreh) #11

Hey, tried the other linked issue, that one was fixed (now it’s .csv.gz that’s downloaded?). My original report, of the Data Explorer does not export to CSV is still erroring out the same way, so this issue is still open.


(Arpit Jalan) #13

I can repro this issue here on meta. Added on my list to fix. :memo:


(Arpit Jalan) #14

Fixed via:

Thanks for reporting this issue @imrehg :+1:

The fix will be deployed on your instance soon.


(Arpit Jalan) #15

This topic was automatically closed after 24 hours. New replies are no longer allowed.