Default terms of service is missing

When I click the FAQ and scroll down to the bottom of that I can find the “Terms of service”. When I click that, it directs to nothing.

I guess there should be a default TOS page somewhere but the link is broken, it shows the page does not exist. No tos tabs are showing as well.

Then, I checked the Admin -> Legal -> tos URL and the value is empty.

I assume, it didn’t get generated at all at the setup for some reason.

I followed the official documentation to install.
github .com/discourse/discourse/blob/main/docs/

Rest of the site works fine.

tried the following code in the terminal as well, but still TOS does not shows up

rake db:seed_fu

How can I place a default TOS in my site? (then I’ll fine tune it later)

The ToS page and Privacy Policy are only generated on new sites when you fill in your company name in the admin settings. If you put something in there, both pages should then show up. :+1:

1 Like

so if I don’t have registered a company to run the forum, then I can’t have terms of service and disclaimers as a person? why only company can have them? What if forum users does something not accepted by public (illegal) and I can’t be liable for their wrong doings? we have to mention it in the site in the form of “Terms of service” to let them that they will be liable for what they post. Eg: acceptable use and content standards.

You don’t have to have a registered company in there, just a name. The FAQs/Guidelines are still generated without adding a company name, and I think a lot of people use those as an alternative to outline acceptable use and content standards if they don’t need the full spread.

1 Like

Is there any way that I can re-generate it as the site is already setup. I’ll write the name of the website then.

If you add something to your company name admin setting it should all work. :+1:


Thank you it worked.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.