Disable Auth0 plugin


(Justin Smits) #1

I have enabled the Auth0 plugin, however I entered in the return url incorrectly or something now I cannot login to the site anymore. I am using a docker setup and so far I have tried the following:

  • commented out the git clone from the hooks section in app.yml

  • removed the following lines under the run section in the app.yml:

    rake plugin:install repo=https://github.com/auth0/discourse-plugin name=auth0
    rm -rf tmp public/assets
    rake assets:precompile

When I hit the login button now, it still tries to redirect with sso in the query string and no login dialogue comes up.


(Ben T) #2

Have you tried running ./launcher rebuild app after making these changes to the app.yml file?


(Justin Smits) #3

Yes. That seems to disable the auth0 window from coming up, however the sso redirect still happens. Does anyone know where the auth0 settings are stored? Maybe I can just edit them manually to fix the problem.


(Ben T) #4

Did you enable the site setting enable_sso? I don’t think you would have had to to enable this plugin, but if you did here is the process for disabling it.


(Justin Smits) #5

Tried that and still no dice


(Ben T) #6

You may be able to access their site setting via the same method (if it’s still active somehow):

rails c
SiteSetting.auth0_callback_url = ''
# or others from their documentation
exit

It may be worth trying to set the ‘connection’ setting to force the default login window to return. Their setting strings are pictured here:


(Justin Smits) #7

This was a huge help and now I am a bit closer. Now when trying to authenticate, I am getting the following error:

Sorry, there was an error authorizing your Auth0 account. Perhaps you did not approve authorization?


(Ben T) #8

Can you register a new account? Then you could promote it to admin from the console and investigate further. If you can not, try editing all the settings there and setting them to ''.


(Justin Smits) #9

I can’t get into admin mode because I either cannot get Auth0 to work with the site or I cannot disable it for some reason. Right now I am stuck with the following error when logging in:

Sorry, there was an error authorizing your Auth0 account. Perhaps you did not approve authorization?


(system) #10

(Joe) #11