Disable memory warning


#1

Hi,

I am hosting Discourse on a VPS with 1GB memory.

I had some issues installing it initially because although it has 1GB installed the environment reports just under 1GB (991448 kB available). I modified the install script to hard code the memory check at 1GB.

It runs just fine and and I don’t have any issues but I am getting spammed daily with ‘Problems have been found’ messages due to Admin panel reporting ’ * Your server is running with less than 1 GB of total memory. At least 1 GB of memory is recommended’.

Is there a way I can disable the message?


#2

Yes? No? Maybe?

I could easily edit the source but any changes I make would be blown away each upgrade.


(Régis Hanol) #3

If you really want to disable that warning then you’ll have to write a plugin that overwrite it.


#4

Sounds like a fair idea, to be clear I’m not so much concerned about the warning message but rather the daily notifications I receive:

I did find an options to unsubscribe from all notifications but it would be handy to still get other warnings if something more serious pops up.