Disabling SSO in development environment

Hello,

I have installed discourse on macOS, following through this(Beginners Guide to Install Discourse on macOS for Development) guide, and it’s worked perfectly fine.

However, I changed some settings to enable_sso and now I can’t login to Discourse with my Admin account. I tried to install discourse from scratch, but I think database records still exist, and I end up with the same problem.

What I am trying to ask here, how can I have really a clean reinstall of Discourse on my macOS.

Thanks in advance.

Our SSO guide has a section on this:

2 Likes

Yes, I was aware of the guide and instructions over there, even I tried those steps, it doesn’t seem that those commands took effect. Anyways, I change site_settings.yml file’s enable_sso component’s value to false and relaunch the server, but this time I am getting an “Unknown error” while I am trying to login with an admin account.

rails c
SiteSetting.enable_sso = false
SiteSetting.enable_local_logins = true
exit

Will 100% disable sso. Maybe you have another unrelated problem?

1 Like

I tried this, but still I am getting the same problem… Might it be related with the force_https options. Every time, I want to test my sso url, I need to setup Discourse locally from scratch, it is really frustrating and tiring. :disappointed_relieved: