Unable to disable SSO via SSH

Hi everyone,

I tried to delete the SSO via SSH, but it’s not working.

I tried to use this command:


root@ser3:~# cd /var/discourse
root@ser3:/var/discourse# ./launcher enter app
x86_64 arch detected.
root@ser3-app:/var/www/discourse# rails c
[1] pry(main)> irb > SiteSetting.enable_sso = false
NameError: undefined local variable or method `irb' for main:Object
from (pry):1:in `__pry__'
[2] pry(main)>

Unfortunately, logging in through admin-login doesn’t work as we had an issue with outgoing emails.

Can somebody guide me on which commands I have to use to disable the SSO through SSH, please?

I appreciate any help you can provide. Thanks!

I don’t think you should be including the irb. Though that also may be an old setting name. What SSO are you using?

Thanks for your reply @JammyDodger

We were using the WP Discourse SSO – but we recently switched back from XenForo to Discourse, and the old SSO wasn’t connected anymore.

I hope someone can shed some light on this one.

1 Like

If it’s DiscourseConnect then I think it would be:

SiteSetting.enable_discourse_connect = false 

And for enabling local logins:

SiteSetting.enable_local_logins = true

Thanks, this solved the issue!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.