Discourse Antivirus in Docker

The docs state that when using it locally you must use the clamav_hostname and clamav_port variables of your discourse.conf file.

In the Docker setup there is no discourse.conf file. But since the configs in the discourse.conf file match the ones in app.yml, i.e. developer_emails in discourse.conf matches DISCOURSE_DEVELOPER_EMAILS in the app.yml. I guess the configs are DISCOURSE_CLAMAV_HOSTNAME and DISCOURSE_CLAMAV_PORT.

However, on Debian the default local installation doesn’t use a TCP port, but a local file socket. Which makes absolute sense. Could you please provide support for a local file socket? This is more secure and has less overhead, resulting in (slightly) more performance.

If this is not possible, then I’ll create a localhost TCP socket for ClamAV and try again. But that seems a bit wrong to do.

Already tried now to configure it locally, but the plugin demands to have an SRV record set. Is this really also needed for a simple local setup?

We use the plugin internally in a distributed system, so this influenced the current design. If you are keen on adding support for settings to make it easier to run it in a single machine setup, please add your plan here and we can help you to write a pull request for this feature.

4 Likes