Discourse Deleting Uploads moved from Local to S3


(Jake Shadle) #1

So we recently moved our on-premise instance of Discourse into the cloud, and as part of the migration we changed from using locally hosted uploads to s3 storage. After running the migrate_to_s3 task and rebaking, images still worked, but some videos were messed up, but we were able to just reupload them and got things up and running as it had been previously, and new videos could be uploaded and played from within Discourse, all was good.

Except, now all of the videos are broken again. Looking at the S3 bucket, we can see that videos are indeed no longer in their normal location eg. original/2X/0/<hash>.mp4 and have been moved to tombstone/original/2X/0/<hash>.mp4 for some reason.

As far as I can tell from the Discourse settings, deletion of uploads should presumably only occur if you enable the “clean up uploads” setting and the post(s) that reference the upload are all deleted, orphaning the upload. But as far as I can tell this should not apply, for example, here is a 5 day old post that worked when it was created, but stopped working after no edits or other action were done that would cause the video to disappear.

Any help on this would be appreciated (hopefully it’s just flicking off a setting I haven’t found?)


(Blake Erickson) #2

I think a fix may have just been created for this a couple of days ago.

Please update your Discourse version and let us know.


(Jake Shadle) #3

Awesome, that definitely sounds like it’s the exact thing we are seeing, thanks!


(Sam Saffron) #4