Discourse embed in Ghost blocked on "Loading Discussion..."


(Jonas Hangvar) #1

Hi,

I’ve setup my Discourse instance and my Ghost on the same server in Docker containers, using nginx to route to the different containers. But when trying to show the Ghost welcome page it gets stuck on “Loading Discussion…”.

I’ve configured embedding for blog.hyzerflip.rip and my code looks like this:

I can’t find anything in the Discourse logs.


(Jeff Atwood) #2

Is there anything in the browser JavaScript console?


(Jonas Hangvar) #3

Good idea! I get these two suspicious responses:


(Jeff Atwood) #4

I meant errors not responses. As in, JavaScript errors.


(Jonas Hangvar) #5

Please excuse my ignorance. Here is a new attempt with JavaScript errors:

Failed to load resource: the server responded with http://blog.hyzerflip.rip/welcome-to-ghost/<a%20href="http:/hyzerflip.rip/">http://hyzerflip.rip/</a>javascripts/embed.js/ a status of 404 (Not Found)

Refused to display ‘http://hyzerflip.rip/embed/comments?embed_url=http%3A%2F%2Fblog.hyzerflip.rip<%%3D%20current_page.url%20%>’ in a frame because it set ‘X-Frame-Options’ to ‘SAMEORIGIN’.


(@SenpaiMass) #6

Hello even as of date i too am getting the same error.


(Sam Saffron) #7

is there anything in the /logs


(@SenpaiMass) #8
Message (634 copies reported)

Job exception: redirection forbidden: http://blog.discuss.moe/thoughts-on-kabaneri-of-the-iron-fortress/ -> https://blog.discuss.moe/thoughts-on-kabaneri-of-the-iron-fortress/
Backtrace

/usr/local/lib/ruby/2.3.0/open-uri.rb:225:in `open_loop'
/usr/local/lib/ruby/2.3.0/open-uri.rb:151:in `open_uri'
/var/www/discourse/lib/freedom_patches/open_uri_redirections.rb:70:in `open_uri'
/usr/local/lib/ruby/2.3.0/open-uri.rb:717:in `open'
/usr/local/lib/ruby/2.3.0/open-uri.rb:35:in `open'
/var/www/discourse/app/models/topic_embed.rb:79:in `find_remote'
/var/www/discourse/app/models/topic_embed.rb:116:in `import_remote'
/var/www/discourse/lib/topic_retriever.rb:56:in `fetch_http'
/var/www/discourse/lib/topic_retriever.rb:43:in `perform_retrieve'
/var/www/discourse/lib/topic_retriever.rb:10:in `retrieve'
/var/www/discourse/app/jobs/regular/retrieve_topic.rb:16:in `execute'
/var/www/discourse/app/jobs/base.rb:154:in `block (2 levels) in perform'
Env

hostname	animeforums-app
process_id	[26401, 19253, 11990, 1694, 175, 23165, 887]
application_version	[cdfe2b814453d24f4d7c98454aac1cdf0c2f61f3, efafdd252ef9df4aedfe2979e9509cfcecaced30, d374913547ad287385edbfee85a05e4f683dc3ab, 605a30254693ea59f42e6c241ee22febb61f7d2d, d7bc8ec752a220128932ef43314ffc237bd6c016, 96c07985b335b64e6fddaf8e9af2ed6feaf24a5d]
current_db	default
current_hostname	discuss.moe
job	Jobs::RetrieveTopic
problem_db	default
opts	null
user_id	[3, 1, 45, 44]
embed_url	http://blog.discuss.moe/thoughts-on-kabaneri-of-the-iron-fortress/
referer	[https://blog.discuss.moe/, https://blog.discuss.moe]
current_site_id	default

The error i am getting as of now.


(Sam Saffron) #9

Why are you embedding a redirect as the URL for the source?


(@SenpaiMass) #10

Thanks for pointing out. I had the domain set to http, even after I added a new certificate. Solved.


(Jeff Atwood) #11