Discourse Hub "connect"

Seeing a difference between a couple of the installations where I’m a user not an admin and don’t want the same thing to happen to my own insatallion. The problem presents as

Authorize application access

Sorry, you do not have the required trust levelto access the user API.

The irony is that I do not see this on sites where I have not yet achieved TL1 but on the site where I see this message I have achieved TL2!

I have looked at User API keys specification but have no idea how the errant site is setup. Suggestions please as I don’t want my installation to produce the same error.

My api skills are still rather shoddy, but is the min trust level for user api key admin setting part of this puzzle? (default TL0)

Most likely. That’s definitely the error message for when your TL is lower than the minimum configured and that’s the only time I’ve ever seen that specific error message and I tend to make the API cry a lot using user api keys. :slight_smile:

1 Like