Discourse installation for beginners but are willing to be part of the community

I see the following error:

A connection to port 80 succeeds, however.
This suggests that your DNS settings are correct,
but something is keeping traffic to port 443 from getting to your server.
Check your networking configuration to see that connections to port 443 are allowed.

Google: "open ports YOUR CLOUD SERVICE" for information for resolving this problem.

You should probably answer "n" at the next prompt and disable Let's Encrypt.

This test might not work for all situations,
so if you can access Discourse at http://beta.example.com, you might try anyway.

Please guide. Advance thanks

The guide says: Google “open porst YOUR CLOUD SERVICE”

Did you do that? Who is your hosting provider?

It’s VULTR cloud hosting.

https://www.google.com/search?q=open+ports+vultr&oq=open+ports+vultr

But there is no rule defined for firewall.

Ok finally I could install it but skipped the lets encrypt email input part!
Next is how to get a let’s encrypt account email to enter at let’s encrypt account email option while setting up; as that is the easiest way to get SSL installed with discourse instance as mentioned by @jomaxro here Advanced Setup Only: Allowing SSL / HTTPS for your Discourse Docker setup

Your link goes directly to the advice I’d give: just re-run ./discourse-setup and enter an email address for Let’s Encrypt to use. It can be any email address that you’ll see, on any domain (i.e., it doesn’t have to be on the same domain as your Discourse installation).

Understood but one must have a account with lets encrypt, and a registered email id to input at setup part!
How to get that?

No, you don’t. Discourse will register the Let’s Encrypt account with the email address you supply. You don’t need to do anything directly with Let’s Encrypt.

But when I did that way I got this error!

However I there is no rule set in firewall settings at my hosting provider, i.e VULTR!

That error has nothing at all to do with the Let’s Encrypt account–as discussed above, it appears that port 443 is not open on your system. I can think of a few possible reasons for this; there may be others:

  • You’re using Cloudflare–if this is the case, disable it. Cloudflare caused the connection to fail for me on either port 80 or port 443 (I don’t recall which, but it was one of those). I mentioned this one several posts up-thread.
  • VULTR has a firewall that’s blocking port 443. I’m sure this would be configurable, but you’d need to determine how.
  • You’ve installed a firewall on your server (I believe ufw is most common for Ubuntu), and don’t have port 443 open.
1 Like

If the particular email id I am providing had been used previously too for a discourse lets encrypt account setup, is it poosible to use same email id again for another instance?

Yes. You can use the same email address on any number of Let’s Encrypt accounts.

This time when done exactly as you told, I can read this error message"

FAILED
--------------------
Pups::ExecError: /usr/local/bin/ruby -e 'if ENV["DISCOURSE_SMTP_ADDRESS"] == "smtp.example.com"; puts "Aborting! Mail is not configured!"; exit 1; end' failed with return #<Process::Status: pid 189 exit 1>   Location of failure: /pups/lib/pups/exec_command.rb:112:in `spawn'
exec failed with the params "/usr/local/bin/ruby -e 'if ENV[\"DISCOURSE_SMTP_ADDRESS\"] == \"smtp.example.com\"; puts \"Aborting! Mail is not configured!\"; exit 1; end'"
62537b933e930ffa2b634521e411afa1ab278759030ac7282f649c160b33d2d4
** FAILED TO BOOTSTRAP ** please scroll up and look for earlier error messages, there may be more than one.
./discourse-doctor may help diagnose the problem.
root@beta:/var/discourse#

This looks like your problem. Did you enter the FQDN of an actual mail server? Or did you enter smtp.example.com? If the latter, that won’t work–you need to enter the actual domain name of a real mail server. You don’t own example.com, so you shouldn’t be using that domain name.

I am using mailgun, so put smtp.mailgun.org

I could install it eventually but without the SSL, with having letsencrypt email entered it did not complete setup successfully!

This guy put up a pretty comprehensive video walkthrough that I used to install my own forums since my previous experience had been limited to ftp uploads and using an install script. YouTube

2 Likes

You don’t need to use that command, as discourse-setup will do it automatically

You don’t need to create /var/discourse as the git clone https://github.com/discourse/discourse_docker.git /var/discourse command will create the directory if it does not exist.

I have updated the instructions in this PR:

It has been suggested that you are using Cloudflare in front of your Discourse (orange cloud is on). Is that true? Use Cloudflare for DNS only or it will cause you problems.

Perhaps INSTALL-cloud and/or discourse-setup should warn against that too.

1 Like

Thank you jimmy for coming up for help, eventually, I am able to do an install, just SSL part is still messed up when installing during the setup(entering email id in Let’s Encrypt email id field) it shows up some error!

And if going by the instructions in Paul’s video here Discourse SSL Lets Encrypt Setup - Secure Your Discourse Forum
My site does not even open up!
I am searching for solutions yet.