Discourse isn't starting


#1

I recently run out of disk space and following this

my discourse isn’t even starting now… I have no idea what to do now and I need help ASAP

It’s a +2000 users community and I would like to fix it now.

This is the error I get when I try to start:

Unable to find image ‘local_discourse/app:latest’ locally
Pulling repository docker.io/local_discourse/app
Error: image local_discourse/app:latest not found


(Matt Palmer) #2

Did you do a rebuild after you cleared up the disk space problem?


#3

Yes I did. The error I posted was shown at the end of the rebuild. I tried rebuilding again, with the same result


(Matt Palmer) #4

Please post the complete output of the command you ran.


#5

Do you mean the whole output of rebuild command? That’s huge


(Matt Palmer) #6

Yes, the whole output. Something is going badly wrong, and the problem could be anywhere in there.


#7

This is what I can get from console after the rebuild is finished:
http://pastebin.com/jfk07HWP


(Wes Osborn) #8

Looks like you’re still low on disk space:

Error response from daemon: ... no space left on device
FAILED TO COMMIT

What does your disk space look like:

administrator@proddiscourse:~$ df -h
administrator@proddiscourse:~# cd /var/discourse/
administrator@proddiscourse:/var/discourse# sudo du -h -d 1 |sort -h -r

#9
Filesystem      Size  Used Avail Use% Mounted on
udev            1,9G     0  1,9G   0% /dev
tmpfs           386M   40M  347M  11% /run
/dev/vda1        20G   19G  1,2G  95% /
tmpfs           1,9G  4,0K  1,9G   1% /dev/shm
tmpfs           5,0M     0  5,0M   0% /run/lock
tmpfs           1,9G     0  1,9G   0% /sys/fs/cgroup
cgmfs           100K     0  100K   0% /run/cgmanager/fs
tmpfs           386M     0  386M   0% /run/user/0
/var/discourse# sudo du -h -d 1 |sort -h -r
3,2G    ./shared
3,2G    .
1,7M    ./.git
168K    ./image
108K    ./templates
24K     ./samples
12K     ./scripts
12K     ./containers
4,0K    ./cids
4,0K    ./bin


#10

Please can someone help me?


(Jeff Atwood) #11

Free up disk space…


#12

How? I don’t know what to delete. Almost all disk space is consumed by discourse and docker


(Rafael dos Santos Silva) #13

Follow this:


(Jeff Atwood) #14