Discourse not sending Emails

Discourse not sending Emails tried everything some times it works sometimes it doesnt losing traffic on my site because of this might just end up shifting to wordpress bb press

Did you check Troubleshooting email on a new Discourse install?

1 Like

yes tried everything suggested there

Well, without telling us anything that you’ve done and what the results were then there is nothing that we can do. The problem is almost certainly with your mail delivery service, and not discourse, so you’ll likely have the same results with any platform.

You send to mail-tester.com and get a 10/10 rating?


You need to show:

What do the Discourse logs say?


What do your email provider logs say?


No, I did not get 10/10 perfect rating, but I got 8.2/10 almost perfect rating as you can see in the screenshot below.

However, this is not the problem. The problem is emails are not even reaching to the email provider platform as evident on its logs. This problem vanishes when I send the restart command to our server and returns again within a time span of 4-6 hours, so the only viable solution we have found is to restart our server 2-3 times in a day which is highly unfeasible for us.

Today, When I login to admin panel, I received this error message, perhaps it may shed some light to you.

Now you need to guide us why this important service of Discourse i.e sidekiq hangs every 4-6 hours and what steps we can take to troubleshoot it?


Ah. Then sidekiq is the problem, nothing to do with mail.

How did you install Discourse? How much ram do you have? How much swap?


I made an account on bitnami.com and then linked my google cloud servers login to that account. and from the Bitnami panel, I used their stack to install discourse on my server.

The configuration of my current server is as follows.
1 VCPU, 1.7 GB RAM, 10 GB SSD.
No idea about swap memory.

If you’re using a bitnami installation package we can’t assist you. Those installation packages are created by a third party and are completely unsupportable here. You’re going to need to ask Bitnami for assistance if you want to use their packages and you will continue to run the risk of such issues arising again in the future.

My recommendation would be to follow the standard installation guide and restore a backup of your site. Any sidekiq issues are likely to be resolved in the process.