Discourse only working on my "www" A DNS record


(Jordan) #1

I’ve got discourse up and running on a DigitalOcean droplet.

I’ve set my “A” DNS records as follows for www.community.jewelbound.com

  • this redirect is working properly!

I have also set up community.jewelbound.com as follows…

  • unfortunately this redirect is not working and I don’t know what to do.

Any help would be greatly appreciated!


(Matt Palmer) #2

Well, step one would be to describe in detail what “not working” means.


(Jordan) #3

Whenever i went to the url without the “www” the page would just be blank and load indefinitely.

I just noticed that it actually IS working now. The page is losing, as expected. I was just tweaking some of the admin settings and maybe that is what made the difference or maybe it just took extra time for the DNS configuration to go into effect :man_shrugging: Thanks for being willing to help!


(Jordan) #4

@mpalmer - another question along these lines just came up…

Now i can access discourse with or without the www

I’m currently logged into the www url. Do you have any idea why i would need to re-login on the other domain without the www? They are both redirection to the same IP


(Jeff Atwood) #5

You need one to redirect to the other. You can’t run a site on two different URLs. The usual way to handle this is via DNS redirection tools in your DNS control panel.