Discourse Upgrade Failed With Ruby 2.4 or above required


#1

I just tried upgrading our discourse forum and a little ways into the installation I got this error:

I updated the the Ruby version in the docker container to Ruby 2.4.4 and set it to the default version using RVM, The default version then showed Ruby 2.4.4 (was 2.3.3). I retried the upgrade and got the same message as in the screen shot above.

I logged out of the docker container and tried a ./launcher rebuild app. After a painfully long time the rebuild failed with the same error message:

Resolution:
I had to completely reinstall Docker with a wget (found the command in the forum) then run the launcher rebuild twice (not because of errors, instructions during the install said to do that). Now have the latest version of docker, postgres, and the forum, best of all I don’t seem to have lost any data and I can login to the forum. Oh, also like all the pretty new graphs in the admin section.


(Jeff Atwood) #2

Ok so … you’re all good?


(Jay Pfaffman) #3

The recommended action would have been to just rebuild from the command line. You don’t need to do anything in the container since the rebuild must makes a new one.


#4

Yes, up and running. Thank you for checking.


#5

That’s what I ended up doing. Started in the forum with “don’t have to login to the machine” upgrade, got docker upgrade ok there, went to update discourse and got the Ruby error. No idea if it was talking about needing it in the container or outside of the container. Took a shot that it was inside the container. After that didn’t work went to do the app rebuild, told me the docker container was at like 1.9.1 and need to be at 17 something tried the apt lxc-docker update, that didn’t work, finally found the command using wget and that got docker updated to 18 something. Then the rebuild was able to start and finished successfully with no errors. Forum was back online. So ya, the update was done through the command line after the preferred method blew up and at 4am in the morning I wasn’t going to complain.


(Sam Saffron) #6

This topic was automatically closed after 2 days. New replies are no longer allowed.