Discourse Wordpress Plugin pulling new discourse categories doesn't work

Hey guys,

i’m having a bit of a hiccup here.
The Discourse Wordpress Plugin doesn’t seem to pull the current categories properly.


I can see the current categories listed in the “Default Discourse Category” in the settings page, however when i try to publish a post it’s showing me an outdated version of categories.

As seen in the screenshots, there are different versions of categories.
I tried the “Force Category Update” Option multiple times, already.

Thanks!

Best,

Daniel

Are you able to open your browser’s web inspector when the Discourse sidebar is being displayed on the new post page? If so, have a look at the inspector’s console tab to see if there are any errors.

Do you have any caching plugins installed on your WordPress site? What version of the WP Discourse plugin is installed on your site?

1 Like

Hi Simon,

thanks for the fast reply.
Im running WP-Discourse Version 1.9.3
My Caching Plugin is LiteSpeed Cache (i have purged the cache, and turned of the plugin, still no change)
Only error showing in the console is:
console-error

Best,

Daniel

1 Like

I am unsure about the cause of the issue with getting the fresh category list in the Discourse sidebar. It seems to be related to caching on your site. I am going to make a small change to the plugin that should fix the issue for you. The change will also allow new categories to be periodically retrieved from Discourse without requiring the ‘Force Category Update’ option to be selected on the Publishing settings tab.

I will try to get this change pushed to the WordPress repo tomorrow, but it may not happen before early next week. I’ll let you know when the updated code is available. If you find out any more about what is causing the issue on your site, please let us know.

6 Likes

I don’t know why, but it’s working now.
The only thing i did, was rebooting my computer
Anyway, thanks for the support!

2 Likes