DiscourseHub Android App compatibility on older Android devices

As The Discourse Hub App looks a bit sad over on the Google PlayStore & looks quite basic for what it is,sadly i cant personally install it to explore its features on my more popular/reliable devices that have never let me down as they run Android 4.0x to Android 4.3 compared to modern devices 5.0 -> 11.

Now i see on the Android Side there is a Beta Program For The App that can be joined but as the app only supports Android 5.0 and above the Android SDK Tag is basically to high to allow installation.

Is It Possible @codinghorror that this can be lowered enough to allow me to install it and in return i can join the beta program and supply private feedback to help bring its low score on the playstore up a bit as things can be worked on in the future.

Last Update was February 2020 however many changes have been implemented to the main discourse software itself since then yet i can still access discourse through a web browser just fine on these devices its a shame the app doesnt do the same.

Im sure others would also like to help with this also.

The app in Android is just a collection of links to opening the sites in Google Chrome and a way to centralize notifications. It does have value, but we have no plans on making efforts to support outdated versions of Android on it. Actually we are bumping minimum Android version to 7.1.1 soon, due to Impact of Let’s Encrypt changes in Discourse users on old Android versions.

3 Likes

Hiya @Falco

Hmmm ??? That is going to upset a lot of users then that maybe using the app under android 7.1.1 and
will render them unable to install updates.

I have read about the new certificate databases and have seen some minor issues regarding this already (not discourse issues).

Bumping up the SDK Tag in the app isnt always a good move especially with android games as users then start to scream at game devs including myself :smiley:

I also have an Android 7.0 Tablet however this 'Bump" will render that not applicable to use/install the app also as im on the highest release (apparently) the tablet can support from the manufacturers and its only a year old (not the o/s).

All i suggest is you think this through as it wont be good for devices out there where the O/S cant be updated even if play store/play services does keep getting updated.

Yes, we are aware of the consequences, but as yourself stated above:

Discourse is a web app, and as long as you have a working updated web browser you have 100% of the features :slightly_smiling_face:

3 Likes

OK SmartyPants.

i’ll be honest my google chrome states its no longer going to be updated however thats what i
use Firefox Mobile For.

i just wanted to use the app version to keep the most commonly used forums all in one place and not
having to switch between
browsers all the time.

The term 'There’s An App For That" doesnt have the same ring as “The web browser version is more compatible for 100% of the features” :stuck_out_tongue:

No need for name calling.


From the beginning of the Discourse project, we’ve been clear that Discourse is being built for the next 10 years of the Internet, and that minimum browser/OS requirements are high. We’ve never officially supported Android 4.0, which was released back in 2011, 9 years ago. 4.3 (released 2013) was the oldest supported version. We have no plans to support old versions of OS/browsers, and will continue to bump the minimum requirements to ensure we can continue building Discourse using the latest technologies.

2 Likes

And soon Android 7 (released 2016) will be the oldest supported version, at least for the Google Play Android app. The latest (and required) patch 7.1.2 was in April 2017.

As long as you can install the latest web browser, you should be able to use Discourse just fine on older versions of Android.

2 Likes

I meant that as only a Joke/Humor and not as an insult,if you wish i’ll edit my post to remove this statement.

i guess untill Google stop offering Android O/S support it will be down to app developers like yourself to make the decision of what versions will be your new base versions eg…chrome/firefox/opera etc.

Firefox Mobile is still supporting Android 4.3 with updates yet chrome has stopped…yet a new game beta came out the other day with a minimum Android SDK of 4.4.2
so its swings and roundabouts i guess.

My Android 8/9/10/11 device just didnt hold up to the standards
these older devices and O/S did and its currently in pieces awaiting repair dont ask.

This was the reason for My question.

www.Oldversion.com Where newer isnt better (aptly named site lol)