Android app crashes if Chrome is not installed

The new Android app crashes without further information if Chrome is not installed on the device.

I’m running 4.4 and I had seen the same issue with the beta app, which is why I tried the same with the release from Google Play.


From the Android app thread:


Surely though it shouldn’t just crash though @sam ? Couldn’t it pop up a message saying “Chrome is required?”


This is now fixed in 1.0.7 which was just released. We will display a proper warning if Chrome is missing.

1 Like

Why the bump in minimum API version? Perhaps I’m missing something, but Chrome Stable is supported on API level 16. Why require 18?

This is @codinghorror’s call take it up with management :slight_smile:

I think it is kind of correct, you should not be running 4.3 or earlier cause you are under a bus.

We should not be encouraging you to run an OS that has publicly disclosed unpatched security vulnerabilities.


I’d like to!

Releasing an app that supports an OS with known security vulnerabilities doesn’t mean you are encouraging usage of said OS. There are many reasons why people are still using said OS, and most are likely not doing so by choice. People buy a phone, and are stuck relying on the manufacturer to update it. Most people can’t just go out and buy a new phone because Motorola, LG, Samsung, or whatever manufacturer they have decided not to update it anymore. Even if Google backported the fix to Android 4.1, most of those devices would still never see the fix!

Actively preventing people from using an app that would work perfectly well on their phones/tablets seems like a bad way to make a statement. If you want to prevent people from using OS’s that have known security flaws, why does Discourse work on XP and earlier versions of Windows? Why support older browsers with vulnerabilities, and not just the newest ones? It just seems very specific that Android is being targetted here, and nothing else. I might be able to support this if the same stance was applied to everything, but targeting one OS is wrong.

1 Like

It doesn’t. Try it.

We don’t. Try it. You’ll get a page urging you to upgrade (unless we broke that recently).

The requirements are listed on our What is Discourse? | Discourse - Civilized Discussion as they always have been

Also requirements move UP over time, not down. We used to support IE9 until Jan 1 2017.

I don’t have a method of installing old browsers, so I’m relying on an online service to test (take it for what it’s worth). Looks like IE does say that an upgrade is neccessary, but Chrome and Firefox don’t:
Chrome 10

Firefox 10

IE 9

As for your comment that XP won’t work: are you saying that if I installed Chrome or Firefox on XP you would detect that somehow and not let Discourse sites load?

XP doesn’t support modern HTTPS.

Note: No versions of Internet Explorer on Windows XP support SNI


I see that. It also says Chrome supports it even on XP.

I’m not suggesting XP should be supported, I’m simply trying to understand how you decide what to support. IE, Firefox, and Chrome have all have severe and critical vulnerabilities patched in most versions, but really old versions are still supported.

The other thing to bear in mind is that devices locked to Android 4.2 or earlier – and cannot be upgraded – are likely to be far too slow to offer a reasonable experience in Discourse anyway.

Discourse itself was not available until Feb 2013, and Android 4.3 was released July 2013.