Displacing a reply to a message


Am not sure if this question has been answered somewhere (tried searching, but I saw nothing related) neither am I sure about the appropriate category.

We run a discourse forum with various categories. A user asks a question under a message that has nothing to do with his question. The right trend for his question already exists.

How do I displace his question under the right trend?

Thanks a million!

1 Like

Do you mean how can you move his post to another topic?

Assuming yes, you click the wrench to the top right of the topic, select the appropriate post and move it to an existing topic.


It is not actually a post, but a reply to an initial post.

Just that his reply has nothing to do with the initial post, I wanted to move it to the appropriate post in the appropriate topic.

Thanks @HAWK


You can use the wrench icon to do this. Click on the wrench and select the post (reply), then select Move to Existing Topic. In the field below, start typing the name of the topic and suggestions will appear as you type. When you get the correct one, select that and Move Post. You will be taken to that topic and the post you moved will appear at the bottom of the list (of posts).


Tanks Jim,

But it’s funny, I can’t see the Move option. Here are the options I have:

Just to be sure, we have version 2.5.0.beta6 of Discourse, can that be the source of the problem? (I mean with the fact that we lack the move option)

Thanks again

1 Like

Sorry that we weren’t clear - use the Topic wrench, not the Post wrench.


Thanks @riking

But even after selecting the replies using the Topic wrench, I can’t still seem to locate the “Move option”

What am I missing?

Thanks again

1 Like

You have to first select a post or posts. You can select individual posts or a post and all the replies below it (careful with that one if there are many posts/replies below it). Once you selected the posts the Move button will appear and give you the choice of moving it to a New Topic or Existing Topic.

1 Like

Thanks @JimPas

I have tried what you said, the problem am having is that I can’t locate the “Move button” anywhere once I have selected the post.

If you look at my previous screen capture, you will realise that I had selected two post, yet there was no move button. I even thought maybe it’s a problem with my browser, but I have tried both on Microsoft Edge and Google Chrome to no avail. We have also recently updated to the lastest version of Discourse…

Thanks again for the time :wink:

1 Like

Something must not be working once you select a post. This is what you should see as soon as you’ve selected the Select Posts… (the top line indicates the number of posts you’ve selected and should change as you add more.


Once you select to move the posts you should be presented with this:


Maybe someone else can chime in here and suggest something. If you are still having this problem, something “broke.” You can try this is Safe Mode and see if the problem remains or not. Another thing to check out are Plugins. One may be interfering mid-way through this process. If you’ve installed a new plugin recently - before this problem arose - that could be the culprit. Otherwise… someone with a lot more expertise will have to suggest something different. Sorry.


Thanks Jim,

Certainly something is broken somewhere.

I will continue digging!


1 Like