How to move posts to a new topic?

Hi -

We’re coming to Discourse from the vBulletin world. One feature I’m accustomed to that I cannot find in Discourse is a “move reply to new thread” feature for admins and moderators.

Does this exist in Discourse, and if so, where?

Thanks for your time and help.

-Justin

3 Likes

Navigate to the Topic
Click the Wrench Icon (top right)
Click Select Posts
Click select on the post you want to move
Click Move to New Topic

18 Likes

You can also initiate via the wrench button at the bottom of the topic, too, if you happen to be near the bottom.

4 Likes

Thank you both. That was easy. -Justin

1 Like

came here hoping this topic was exactly about this and will leave satisfied… :triumph:

1 Like

huh - I never noticed that second (third!) wrench on the bottom left corner.

that was exactly the information that i was looking for. thank you :slightly_smiling:

It would be nice if you could initiate a move from the wrench directly associated with the post.

11%20PM

Much easier than running through the Select Posts approach.

3 Likes

I’ve also been thinking that, but the problem is, you can’t get rid of the select-posts-and-then-move way of doing it because you need it for moving multiple posts. So if you add a “move this post” item to the individual post menu, you will probably have people wonder “but how can I move multiple posts?”. At least that’s how I tried to make sense of why it isn’t there…

3 Likes

Just checking - is it not possible to break selected posts into a new topic if they all consist of whispers?

In my Staff category, I wrenched, selected everything below, “move to” and I can only select an existing topic. Is this a behavior specific to whispers - IE it’s not finding any “real” posts to create a topic from? (I guess that would make sense since whispers are supposed to refer to the current posts in the topic.)

Similarly, there doesn’t appear to be a way to “unwhisper” something, but I would also guess that’s intentional so private comments don’t get revealed accidentally.

2 Likes

That is an unusual use case cc @techapj

3 Likes

I’m trying to move a reply in a topic to a new topic. As far as I can tell, the topic / post doesn’t have any security settings that would restrict what I can do with it e.g. it’s not a whisper. I can move other replies in the topic, that were posted before & after the post that I can’t move, to new topics.

The user whose post I’m moving is at trust level 4 but isn’t an admin or a moderator. I’m trust level 4, an admin & moderator.

If I choose ‘select+below’ when I select the post I’m trying to move, I still don’t have the option to move the posts to a new topic.

Is there anything else that could be limiting my ability to move this post?

Are you on the latest beta version of Discourse?

Yes we’re on 2.3.0.beta9 when I check via page source.

@zogstrip has recently changed the possibility of creating new topics from whispers to prevent broken topic

https://github.com/discourse/discourse/commit/5c1eaeca9e783aec07191958f0781ad9e57c0f22

Ref to Moving whisper posts to a new topic creates a broken topic

3 Likes

Try to open the dev console with f12 and switch to the Console tab before trying the move. Do you see errors?

No I don’t.

I should have mentioned - this is the only option I see when I select the post, I’m not able to go through the process of creating a new topic & then trying to move the post.

If

you can move other posts to new topics without problem there is an issue with that post only. Can you find or create another post with a markdown table and move it to see if you can move it to a new topic or only to an existing topic?

Probably you have some plugins or themes that are interfering.


As a workaround for the problem you can copy the post from https://community.freetrade.io/raw/8235/12, delete the original post, paste the content in a new topic and ask an admin to change the ownership of the topic to the original author.

1 Like

I’ve just tried this & I do have the option to move the post both when I’m the owner of the post & when it’s owned by the owner of the post that I’m having an issue with.

Here’s the post -

44

in case it helps, here's the full markdown for the post that I'm having an issue with
@weenie I've gone ahead and created a table that tracks our status with a few publications that have comparison charts, here. 

|Company Name|Link to comparison chart|Status|
|---|---|---|
|Money.co.uk|https://www.money.co.uk/savings-accounts/investment-isas.htm|No - only paid opportunities with providers|
|Monevator|https://monevator.com/compare-uk-cheapest-online-brokers/|Yes, included in comparison chart|
|Money Saving Expert|https://www.moneysavingexpert.com/savings/stocks-shares-isas/|Reached out & held briefing with reporter - pending coverage|
|BoringMoney|https://www.boringmoney.co.uk/learn/investing-guides/product-guides/stocks-shares-isa/|Coordinating inclusion in future stocks & shares ISA charts|
|Money Super Market|https://www.moneysupermarket.com/investments/stocks-shares-isas/|Reached out - awaiting response|
|Good Money Guide|https://goodmoneyguide.com/stock-brokers/|Yes, included in comparison chart|
|Which? |https://www.which.co.uk/money/investing/fund-supermarkets/fund-supermarkets-reviewed|Reached out - awaiting response|
|Stockbrokers.com|https://uk.stockbrokers.com/compare|No, need to have VC funding ahead of review|
|Broker Chooser|https://brokerchooser.com/compare-brokerage|Reached out - awaiting response|
|The International Investor|https://the-international-investor.com/comparison-tables/cheapest-uk-online-stockbrokers|Reached out - awaiting response|
|Finder|https://www.finder.com/uk/share-trading|Reached out - awaiting response|
|Compare Fund Platforms|http://www.comparefundplatforms.com/|Reached out - awaiting response|
|Motley Fool |https://www.fool.co.uk/money/buy-shares/|Reached out - awaiting response|

If you can think of any more places we should be, comment below :) We'll keep the table up to date!

If you do not have access to the site logs, plugins and themes it is difficult to help you, but if the problem is related only to that particular post you can recreate it and then ask for the ownership to be changed.