Docker dev only starting critical sidekiq queue


(Leo McArdle) #1

Currently when using d/sidekiq to run sidekiq in the docker dev image, it starts a sidekiq process only for the critical queue.

The problem line is:

When I change sidekiq -q critical,low,default to sidekiq -q default,critical,low it starts a process only for the default queue, so there’s something wrong with the commas.

The workaround I’m using is just removing -q critical,low,default in its entirety, which starts a process servicing every queue.


(Sam Saffron) #2

Sure, send a pr through to fix


(Leo McArdle) #3

(Sam Saffron) #4

are you 100% sure of that, I am finding this super confusing


(Leo McArdle) #5

Yep, but from playing around I’ve also found -q critical -q low -q default works, which is a clearer fix, so I’ve updated my PR.


(Régis Hanol) #6

(Alan Tan) #7

(Alan Tan) #8

I believe we don’t need to pass the queue options in dev since we have


(Jeff Atwood) #9