Edit Conflict on Wiki Posts

Continuing the discussion from Edit Conflict: That post was edited by another user and your changes can no longer be saved:

My forum has started seeing the “Edit Conflict” again. It now seems to be contained to Wiki posts edited by more than one user.

This is NOT happening when people are editing at the same time, this is happening when a different user tries to edit a post that was established.

Example:

  • Initial post by user 1
  • Edit by user 1
  • Edit by user 2 sees “Edit Conflict” and the 1st edit by user 1 has disappeared.

The only solution we’ve found is to back out of the post and refresh the page (sometimes twice) and then we can proceed.

Hmm, I am not immediately able to reproduce the issue. In case I am not following the steps you are taking, here’s a video of what I have tried. Let me know if there are additional steps I need to take. It may also be helpful to know what statuses the involved users have (e.g. admin? moderator? what trust level?).

All involved posters are Moderators.

We have news posts that we update throughout the day.

User 1 posts the initial post and submits. Then, usually at least 45 minutes to an hour later, same user edits to add another article.

User 2 comes along later (maybe another hour) and starts to add to the post, only to receive the “Edit Conflict” warning at the bottom of the posting pane.

We (the mods) have discussed this at length, so we’re being very cautious when more then one of us is posting so we watch for it.

I have not recreated it here since I haven’t run across any wiki posts to edit.

1 Like

Ok, I was able to get the edit conflict to trigger. It seems like it happens when a tab/window that is open to the wiki post gets stale. The windows in the following video had been sitting for about 20 minutes with no interaction. Note that the edit conflict message at the end might be a little hidden behind the video progress bar.

@sam what do you think? Is this expected behavior? MessageBus issue?

1 Like

I see, @nbianca do you remember looking at this. I recall we used to delay the edit till we pulled the latest “raw” for the post.

I think it is correct to always protect against missing message bus messages.

Technically this looks a bit like a message bus glitch. I added some code in the past that is meant to recover and switch back to long polling when you reactivate an old tab, but maybe it is missing this particular usage case.

2 Likes

Your code was good, but MessageBus API changed at some point and it did not work anymore. I fixed two bugs related to this in a PR: