Emacs Keybindings


(Bodo) #1

I really love using Discourse. It is really awesome to read a discussion on it. Sadly I have a little problem when joining a discussion. The editor overwrites the default emacs keybindings on my mac with own functionality. For example ^h creates a headline, ^b a bold text. I use the emacs keybindings to enter text because I don’t want to move my hand to the cursor keys.

Is it possible to disable those keybindings?

Ah and another problem with those overwrites: they somehow destroy the undo history. When I press them accidentally, I can’t undo it :frowning: .


(Sam Saffron) #2

you would need a user script to disable it. no built in method


(Bodo) #3

Would you consider to add this as an optional setting for the user?


(Sam Saffron) #4

seems too edge casey for me … not sure if I support that


(Bodo) #5

Can you pinpoint the location in the code that does this so that I can write a userscript for this?


(Sam Saffron) #6

somewhere in the composer, don’t know the line off the top of my head.


(Bodo) #7

Found it. It’s in MarkdownEditor.Editor.js#1228.

But it still would be awesome if there was a setting to overwrite this within Discourse.