Email no longer works


(Ankh2054) #1

Hi all,

Im stuck in that my discourse will not send email. I bootstrapped my discourse, configured the main account using developer email and received the email. I started to import my old phpbb, but realised I needed to prune some user so I had to start over.

My steps:

  • delete /shared/* & stopped the docker container.
  • rebuild using ./launcher bootstrap app
  • tried to register using the developers email, but this time I’m not getting any email.
  • ./launcher enter app and tested SMTP - telnet smart.server.com (as used in app,ml) and successfully received the email.

UPDATE

The problem was due to my importing loads of posts from a older phpbb3 forum. Upon app rebuild, the discourse/lib/tasks/posts.rake would run and id had to download 10000’s of images from the web to replace embedded image links. This seems to take priority over registration emails/


(Ankh2054) #2

Ive alsed tried to add yahoo as my SMTP and same problem. How weird…


(Jeff Atwood) #3

See the email troubleshooting guide. We also strongly recommend you use Mandrill for mail, which is free for up to 12k sends per month.


(Ankh2054) #4

thanks Jeff,

I configured mandrill in the end, but I had the same issue. Not sure why this matters, but this could it working.

I confirmed app.yml, then ./launcher bootstrap app.
At this point it was still picking up the old email addresses, but the correct URL for the site…
I then ran ./launcher rebuild app and it picked up the new dev emails and I could receive emails.


(Jeff Atwood) #5