Enable noreply incoming e-mail from Discourse?

Hi there. I wonder if there is possible to forward (or don’t manage, better) the incoming e-mails that friendlynoreply@mydomain.com recieves and stop auto-reply in that address.

I readed some guides and Postfix configuration but I really don’t get it. I’m looking for the best option to manage incoming/outgoing e-mails in my site and I’ll like to be allowed to reply this kind of e-mails.

Thanks for your time.

1 Like

You should really let discourse handle all of it’s emails.
for sending emails, I’d assume you’ve configured an external SMTP (e.g. mailgun) and for receiving a standalone MTA (e.g. mail-receiver container). I don’t think discourse ever auto-replies to any email unless there are issues (e.g. incorrectly formatted email address).

If You follow the guides correctly, The setup looks like this:
All system emails are sent via noreply@discourse.example.com while the emails that expect a reply (notifications) are sent from reply+{reply_key}@discourse.example.com All the outbound mail is processed via your ESP and incoming is Processed via the MTA neither should have the ability to do the vice-versa (i.e. ESP can’t receive and MTA can’t send)


It’s done. I was using Mailjet but this service only enable to send mails. Tried a lot of services and for now I keep with Zoho.

Thanks for your reply. That’s exactly the way I setted up.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.