Err_connection_refused

Hi!
I have installed discourse and rebuilt it after changing a setting in the app.yml. When i went to load onto the site to set it up via IP:Port I get ‘ERR_CONNECTION_REFUSED’. The docker container seems to be running fine portainer shows Port:80 so I know the system has bound my custom port to port 80 on the container. My custom port is allowed through UFW so im not sure what is up. Does anyone have any ideas on how to fix this? If i try to connect through my subdomain(using the reverse proxy) I get 502 bad gateway.

Kian

You have to run it with a domain name on port 443.

Hi!
I am using a reverse proxy with apache which is using SSL. So I disabled SSL on discourse itself. Would the best option be stopping apache so ports 80 & 443 are free, then install discourse. Then after change the port and rebuild the container? Would that work?

Hi!
I fixed this!
I was told I need to run discourse in a websocket for using a reverse proxy but I commented out this line and now the site works.