Error: GIFPHY API key is not set

I followed the instructions found in the thread, Discourse Gifs, however, when applying the API key, when attempting to apply a gif in a post, I still get the same error message that reads as follows:

But I did this already. I’ve uninstalled the component and reinstalled the component and after entering the correct API key, I still get the same message.

Forgive me, but do I have to “Upgrade to Production Key”? It requires that I somehow take a video of how I will use the “gif” in Discourse. Is this essential to get this working, or is that for huge business sites? We are a very very small site with about 20 users at present.

Please advise. Any help would be greatly appreciated, and if anyone has experience getting as far as I have, did I not go far enough? Is there more to do?

I’ve set GIPHY up on one of my sites and I haven’t used the “Upgrade to Production” button. I do recall having a false start setting it up, but I don’t recall the details at the moment.

The API key is easy enough to find on the GIPHY dashboard. Make sure it matches giphy api key in the discourse-gifs theme component settings, I guess? The only other non-defaults I have set are:

  • giphy content rating = “pg”
  • limit infinite search results = true

Of course I also made sure the component is enabled on the default theme.

Not sure this helps you, though. :-/

1 Like

Thank you, Jon. I’ll give it a shot in the morning and let you know how it goes. Thank you :blush:

Also given recent Giphy announcements regarding price, I’d recommend trying out Tenor too.

@jericson, that did the trick! Thank you!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.