Error loading the individual group when using allow pm to staff plugin

When I am going to the Groups page (, it is fetching all the groups but when I try to enter into any particular group it is giving me the below error, this error is coming with all the groups

I am the owner of these groups and I have checked this from the normal user’s account too and these same errors is coming with this particular user type too.

Kindly help me to fix this issue.

Could you check your \logs or browser console when trying to access the group to see if there’s more detail about the error in there?

Thank you for helping,

This is the errors getting on the browser console

Could you expand those errors and copy the message into a codeblock here?

/groups/EPiC.json:1          Failed to load resource: the server responded with a status of 500 ()
application.js:83 Objectabort: ƒ (e)always: ƒ ()catch: ƒ (e)done: ƒ ()fail: ƒ ()length: 0name: "add"prototype: {constructor: ƒ}arguments: (...)caller: (...)[[FunctionLocation]]: jquery.js:3535[[Prototype]]: ƒ ()[[Scopes]]: Scopes[4]getAllResponseHeaders: ƒ ()getResponseHeader: ƒ (e)jqTextStatus: "error"overrideMimeType: ƒ (e)pipe: ƒ ()progress: ƒ ()promise: ƒ (e)readyState: 4requestedUrl: "/groups/EPiC.json"responseJSON: error: "Internal Server Error"status: 500[[Prototype]]: ObjectresponseText: "{\"status\":500,\"error\":\"Internal Server Error\"}"setRequestHeader: ƒ (e,t)state: ƒ ()status: 500statusCode: ƒ (e)statusText: "error"then: ƒ (t,n,i)[[Prototype]]: Object
error @ application.js:83
router.js:1064 Error while processing route: group.members
(anonymous) @ router.js:1064
rsvp.js:23 Uncaught ObjecterrorThrown: ""jqXHR: abort: ƒ (e)always: ƒ ()catch: ƒ (e)done: ƒ ()fail: ƒ ()getAllResponseHeaders: ƒ ()getResponseHeader: ƒ (e)jqTextStatus: "error"overrideMimeType: ƒ (e)pipe: ƒ ()progress: ƒ ()promise: ƒ (e)readyState: 4requestedUrl: "/groups/EPiC.json"responseJSON: error: "Internal Server Error"status: 500[[Prototype]]: Objectconstructor: ƒ Object()hasOwnProperty: ƒ hasOwnProperty()isPrototypeOf: ƒ isPrototypeOf()propertyIsEnumerable: ƒ propertyIsEnumerable()toLocaleString: ƒ toLocaleString()toString: ƒ toString()valueOf: ƒ valueOf()__defineGetter__: ƒ __defineGetter__()__defineSetter__: ƒ __defineSetter__()__lookupGetter__: ƒ __lookupGetter__()__lookupSetter__: ƒ __lookupSetter__()__proto__: (...)get __proto__: ƒ __proto__()set __proto__: ƒ __proto__()responseText: "{\"status\":500,\"error\":\"Internal Server Error\"}"setRequestHeader: ƒ (e,t)state: ƒ ()status: 500statusCode: ƒ (e)length: 1name: "statusCode"prototype: {constructor: ƒ}arguments: (...)caller: (...)[[FunctionLocation]]: jquery.js:9487[[Prototype]]: ƒ ()[[Scopes]]: Scopes[4]statusText: "error"then: ƒ (t,n,i)[[Prototype]]: ObjecttextStatus: "error"[[Prototype]]: Object
DevTools failed to load source map: Could not load content for chrome-extension://gighmmpiobklfepjocnamgkkbiglidom/ System error: net::ERR_FILE_NOT_FOUND
/message-bus/eb47113e4410479497a7f26dedf3819c/poll:1          Failed to load resource: net::ERR_QUIC_PROTOCOL_ERROR

Do you get the same errors using safe mode?

I tried safe mode too but still getting the same error.

Kindly help me to resolve this issue as soon as possible as this is getting really critical for us, no one is able to join any of the groups.

Note - I have upgraded all the plugins and my discourse is on latest version as of now.

I’m having trouble reproducing this on my test site. Do you have any non-official plugins on your site that may be having an effect? Or any other notable differences/quirks that I could try to see if I can replicate the issue?

I am using these plugins only. I tried in safe mode too and still getting those errors as in the safe mode it disables all the plugins.
Is there any thing more which is needed from my end to reproduce the error then please let me know.

I’m afraid safe mode only disables front-end code and not server-side stuff (which catches most things, but not everything) so it could still be a plugin. The most likely one is the allow-pms-to-staff as it’s the only non-official one in the list. You could try removing it from your app.yml and rebuilding to see if that is indeed causing the issue?

There was a report of it needing a fix for something else recently, though it may be unrelated:


Ok let me try this too.

Let me know if removing the plugin fixed the problem. I don’t see how the plugin would do that but I also see no other reason you’d have that problem.


yes, you were right this plugin is causing the problem. After removing the plugin now it has started working.
@pfaffman please kindly fix it as your plugin is very necessary for us.


Wait so this is a bug in the unofficial plugin GitHub - pfaffman/discourse-allow-pm-to-staff: Allow private messages to be sent to staff for users who could otherwise not send private messages.

Moving this to support

@pfaffman not seeing a topic for this plugin?


Indeed. I mentioned it offhandedly, not really expecting anyone to use it. :person_shrugging:


I really think this functionality should be in Discourse core, especially the ability for all active users to send a new PM to staff regardless of their trust level or PM rate limit. I’ve received many (public) reports from new level 0 users that were trying to contact me and couldn’t do so. And enabling general user-to-user PMs for level 0 users is a bad idea.

Yes, the problem is fixed now after the latest changes in the plugin

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.