Experiencing touch offset issues replying on Android

More info. It seems to only impact initial load.

I’ve had to exit chrome to reproduce again.

Exit Chrome
Navigate to Meta
Navigate to topic
Reply to Topic
Enter a line or 3 of text
Click title
Scroll to bottom quickly
Click text box to focus on reply
Offset occurs

To fix:
Navigate away from topic (latest)
Refresh page (composer should disappear)
Navigate to topic (composer restores)
Hit reply

Once it is fixed I can’t get it to happen without closing chrome. It seems something in the initial setup of composer is causing this. Not sure what though.


Our members tried your combo but cannot reproduce :expressionless:

Cannot reproduce what? The fix or the issue?

They tried To do the manipulation but the bug did not happen.
The description seems to be our issue. There is a vertical offset and to be able to reply they should click 2cm below the bottom of their screen

Can you repro this @falco? I will try to repro later tonight with my test Android device when I am back home.

Ok just made it reproductible on my lg G5.
I just have To scroll UP to have a google overlay on bottom that propose me to translate the page to french. At that point the offset occurs at each try.
On the video posted by one of our member. A google overlay is also visible at some point.

@codinghorror @Falco did you succeeded to repro ?

1 Like

Yes, I just managed to repro this on the Discourse China website.

Only affects the composer modal, which will have the vertical offset.

This looks like a Chrome bug because even the Chrome Inspector goes crazy:

Where the textarea is:

Upload button:


Can we use the mitigation @sam suggested?

It’s like a race between the location bar and the Google Chrome Translate bar.

I’m testing if changing:

#reply-control { position: fixed; }


#reply-control { position: absolute; }

fixes it.

EDIT: won’t work.


Is this a chrome bug? should it simply be reported to chrome first?

I got some simple steps to repro:

  1. Go to a long topic (this topic here works)
  2. Open Composer
  3. Scroll until a new post chunk is loaded.
  4. The click are for modals will be offset from the screen position. (You can do this in both ways, so they are draw above or below if you trigger the bug going up or down).

This does not repro for me on oneplus 6, updated to latest. Here’s what I did:

  • clicked on the post count and selected the first post to enter this topic at the top
  • opened composer by pressing reply on the first post
  • scrolled to the bottom of the topic

I don’t see any offset on taps there?

For the record, mine didn’t require a translation bar but I also think this is a chrome bug because it’s being reported at sitepoint and I know they are not on latest.

Edit: l just had it happen to me visiting this topic immediately and doing nothing else. I used speech to text which might have impacted it but further goes along with this being a chrome issue

1 Like

Same thing.

All you need is the address bar on Chrome auto-hiding and eventually it will desync divs that user either position fixed or sticky.

I never experienced this before because I use the WebAPKs that doesn’t have the location bar.


I’ve followed that video as precisely as I can, 3 times, and I just can’t get this to repro on OnePlus 6, latest everything, device at all defaults (I unboxed it, updated it to latest versions of apps/OS, then loaded Chrome).

So I wonder if it is an internal Android / Chrome timing issue of some kind?

I do think your theory of the address bar de-syncing sounds correct, since the offset appears to be exactly the address bar size.

1 Like

Possible related bugs:



OK! Here’s one thing I can repro, OnePlus 6, everything at latest updated versions:

When the Chrome address bar is suppressed (via scrolling down), I cannot tap on the bottom-most area in the Chrome viewport where the minimized composer is. It’s physically impossible, my taps don’t register at all!

I have to scroll the viewport up, to bring the Chrome address bar back. Then, and only then, am I able to tap on the area at the bottom of the viewport where the minimized composer is.

So the repro is:

  1. Start composing a reply, type some text in the reply box
  2. Minimize composer.
  3. Scroll down ↓ to force the address bar to disappear.
  4. Try tapping on the minimized composer at the bottom of the viewport; you won’t be able to.
  5. Scroll up ↑ to force the address bar to reappear.
  6. Try tapping on the minimized composer at the bottom of the viewport, it will work fine.

TL;DR there appear to be internal bugs in Android Chrome around the address bar appearing or not appearing, causing it to calculate taps wrong, offset by exactly the address bar height. As a workaround, make sure the address bar is visible by scrolling ↑ up.


Just tried to reproduce and could not. Opened fine when I tapped it with the address bar hidden. Pixel 2 XL

1 Like

What version of Chrome and Android? I should have reported mine…

Chrome 67.0.3396.87
Android 8.1.0