"FAILED" error selecting Favorite badges

  1. Two badges already selected.


  1. Click once to try to deselect a badge.


  1. Didn’t work.


  1. Click again to try to deselect the same badge.


  1. Worked this time.


  1. Click once to try to select a new badge (New User of the Month).

Repeated clicks to try to select yield the same result. I also noticed that the Discourse banner disappears underneath when the FAILED modal pops up.

4 Likes

Sorry, @riking. Somehow I stepped on your topic title edit. No idea how I did that and I certainly didn’t intend to. Maybe another bug?

I manually corrected the topic title afterwards. I had somehow restored it to the original without even trying.

1 Like

The bug persists. I cannot deselect or select favorite badges at all any more, so my displayed badges are now frozen in time.

2 Likes

:musical_note: :snowflake:

They won’t go, they won’t go
Can’t choose badges anymore
They won’t go, They won’t go
They’re both frozen to the floor
They’re forever here and going to stay
Let the clicks rage on
I hope there’s a fix coming any day

:pray: :wrench:

1 Like

Thanks for the report. We’ll have it fixed.

2 Likes

1st click will make the badge selected but the star icon is not displayed as “filled”, if refresh the page will see it was selected and the badge is displayed on user card properly.

But with the display issue, when user click the second time, the star icon will show as filled which actually cancel the selection.

I see it also happens on meta.

2 Likes

Thanks for the feedback, we have assigned the work to one of our engineers and they’ll report back when completed.

3 Likes

Harsh crowd…

:sweat_smile:

Thanks in advance to all involved for the upcoming fix though.

:slightly_smiling_face:

2 Likes

This PR fixes problems with selecting favorite badges:

1 Like

I can confirm that it works! :smiley:

I do have to remember to only single-click on the star, ignore the fact that the selected count doesn’t update, and refresh the page to see the proper results. If I click the star twice so that it appears to be unselected, the count at the top decrements, but when I refresh, the count reverts and the badge is still selected.

In essence, clicking the star once doesn’t seem to refresh the state of the page while clicking twice does. However, correct underlying functionality is only had from a single click and a manual refresh.

1 Like

Oh, I’m able to reproduce the problem. Now it is some client side quirk. Jonathan, thanks for reporting! I’ll take care of this and post updates on this topic.

1 Like

Hmm, wait, we haven’t merged it yet. I’m going to merge it tomorrow. @griffin my PR should fix the behaviour that you’re describing. I’ll double-check it anyway.

1 Like

Interesting…

So it may be that the functionality was there, but that the appearance was deceptive. Either way, hopefully your PR will squash this bug once and for all! :slightly_smiling_face:

:bug: :hammer:

1 Like

Ok, it’s merged now, after updating everything should work fine.

1 Like

I can confirm that this bug is thoroughly smashed! :smiley:

This topic can be closed.

2 Likes