Failed to create swap: are you root?

I bought a Ubuntu 18.04, 64bit VPS from Hostinger and I’m trying to install discourse but keep getting this error:

1 Like

What Hostinger plan are you on?

1 Like

I’m currently on plan 2, this is what best fit the requirements per instruction here: discourse/INSTALL-cloud.md at master · discourse/discourse · GitHub

1 Like

Is this their VPS offer from VPS Hosting | Cloud-Based VPS | 30X Faster | Up to 77% OFF ?

This error, like the error message says, means that this isn’t a real hardware and neither a full virtualization.

I checked Hostinger page, and for their “cloud hosting” product they use LVE containers which won’t work out of the box. Unfortunately their VPS page has no information about the virtualization technology they use, so I suggest you to contact their support and ask about it.

If you want a provider that is know to work we recommend DigitalOcean as said in the official guide.

3 Likes

I couldn’t get DigitalOcean to work sadly, I prepaid with 25$ and they locked my account immediately after.

3 Likes

Oh sorry to hear that. I had that happen to me in some providers…

The vultr that costs $5 from High Performance and Cheap Cloud Servers Deployment - Vultr.com also work.

3 Likes

Thank you, I will have a look

1 Like