Forum offline: Restore is not working through web

I made a big mistake tonight and accidentally nuked my forum in DO. So I cannot restore from a snapshot. I recreated a Discourse instance, but I cannot upload my backup through the web. It uploads up to about 17%, and then starts over, until it errors out with an error popup that says try again.

I tried following the command line restore, but it’s not working or I’m probably doing something incorrect. I would sincerely appreciate any help right now. I’m dead in the water.

Have you tried copying it onto the server using another method such as scp?

Once it’s on the server, you can move it where it needs to be to be restored.

I did, but it doesn’t seem to be working…

I followed the instructions at the link I included which state:

My Steps

So in my case, from the root command line I typed:

mkdir -p /var/discourse/shared/standalone/backups/default and hit enter.

Nothing happens, except a new line break.

Then I typed:

scp /Users/brandon/Downloads/forum-name-2023-05-17-011157-v20230510142249.tar.gz and hit enter.

The read out says,

usage: scp [-346ABCOpqRrsTv] [-c cipher] [-D sftp_server_path] [-F ssh_config]
           [-i identity_file] [-J destination] [-l limit]
           [-o ssh_option] [-P port] [-S program] source ... target

Then I typed,


Then it says, “No such file or directory”

I did substitute the IP for my forums IP address. I just don’t get why the restore steps are not working here?

Don’t hit enter between the source and destination, it’s all a single command.

Thanks Michael, I did try that as well.

root@discourseonubuntu2204-s-1vcpu-2gb-nyc1-01:/var/discourse/shared/standalone/backups/default# scp /Users/brandon/Downloads/my-forum-2023-05-17-011157-v20230510142249.tar.gz root@
root@'s password: 
/Users/brandon/Downloads/my-forum-2023-05-17-011157-v20230510142249.tar.gz: No such file or directory

“No such file or directory” ???

You need to run that on your machine where you have the backup.

It’s intended to copy it to the server.

Yes, I’m running the command in Terminal on my Mac, and I’m consoled into the DO Droplet.

I can confirm, the .tar.gz file lives in the “/Users/brandon/Downloads/” folder on my Mac.

I’m puzzled.

Hi, Brandon

The scp command should run in your local machine, not your discourse server.

Your command should like be this…

brandon@your_machine_name# scp /Users/brandon/Downloads/my-forum-2023-05-17-011157-v20230510142249.tar.gz root@{{your forum ip}}:/var/discourse/shared/standalone/backups/default/

I cannot thank you both enough for stepping up to the plate here. I did not realize I run that locally and not on the server. :man_facepalming:t3: I got it back up and running. I would have been up all night with nothing to show for it if it wasn’t for you two. Thank you so very much!


To clarify: you’re typing it in on your Mac but running it on the server.



This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.