<forum>/search returns 500 error


#1

On my forum and on this forum, if I go to http:// forum address /search I get a 500 error.

Any known workarounds?

Thanks!


(Tomas Ibarra) #2

Can you give the complete address?


#3

https://meta.discourse.org/search


(Tomas Ibarra) #4

I’m not sure if this is a correct address for this application, is it? @zogstrip @codinghorror @sam


#5

I’m not 100% sure it worked on this forum before, but it definitely worked on mine: http://talk.sparrowbrowser.com/search


(Tobias Eigen) #6

This looks like a legit bug, though not high priority since few people will find themselves here.

If you search for e.g.

Search results for 'community land protection' - Global Legal Empowerment Network Community Discussions

you get results.

But if you visit …

Search results for '' - Global Legal Empowerment Network Community Discussions

… or even …

Search results for '' - Global Legal Empowerment Network Community Discussions

… you get an ugly error.

Would be more sensible to be shown a blank search form ready to be used to search for something.


#7

Yeah, using the magnifying glass link works just fine. For us this is an issue because we liked the /search page a lot and are pointing people toward it.


(Mittineague) #8

Not what I’m getting using Firefox by a direct click on the link

But if I put the URL into the address bar I get a blank page.

A relative link thing?


(cpradio) #9

Weird, I get a Server 500 error


(Tobias Eigen) #10

me too. In Chrome, I get the server 500 error, here on meta and in our community.


(Tomas Ibarra) #11

Seems that the bug is in chrome, i got and error too.


#12

Interesting to know that it’s browser-dependent!


(Arpit Jalan) #13

I can repro this issue locally, working on a fix now.


(Arpit Jalan) #14

Fixed via:

Was related to this commit.

cc @sam


(Tomas Ibarra) #15

Can you explain me how the ‘if result’ works in this case? I will appreciate it a lot.


(cpradio) #16

It will only run find_user_data(guardian) on result, if result has a value. In this case, since you are visitng /search directly, there is no result


(Tomas Ibarra) #17

Oh i got it! Thanks for the explanation, cheers! I think this post should be closed right?


(Arpit Jalan) #18

Yep, search page loads fine now: Search results for '' - Discourse Meta


(Arpit Jalan) #19