Fresh install stalling at admin access


(Alex) #1

So I’m trying to get a basic Discourse server set up, followed the basic install guide, everything boots up correctly. Got to the initial registration page, put the admin details in, and then receive the confirmation email. That’s where things stall: when I click the confirmation link, it appears with the button to confirm/activate the account, but does nothing when clicked on, acting like a dead link. I’ve tried a couple of reboots, wiping everything and starting over completely, and all seem to be doing nothing. Not sure where to go from here. I’ve included a screenshot of the page in question. /wizard doesn’t exist yet either, as I tried on a previous attempt to manually add admin access, which just resulted in a blank page and no /wizard or /admin. I’m not sure what I’ve done differently, as I had previously installed a Discourse to another Linode with no issues.


(Rafael dos Santos Silva) #2

Can you please check the DevTools for any error in the logs? (Pressing F12 opens a panel that contains a tab for Console logs in most browsers)


(Alex) #3

Looks like this is the issue:

Loading failed for the <script> with source “https://ajax.cloudflare.com/cdn-cgi/scripts/a2bd7673/cloudflare-static/rocket-loader.min.js”. 2e2ae61b862b35ed9451a5257abf6d74:51:1
Content Security Policy: The page’s settings blocked the loading of a resource at inline (“script-src”). Source: ;!function(){var t,e,n,o=0,u=function(t,e){return"function"!=typeof t||t.replaced?t:(e.replaced=!0,e)};if("undefined"!=typeof CustomEvent&&"function"==typeof window.dispatchEvent){var r=function(t){try{if("object"==typeof t&&(t=JSON.stringify(t)),"string"==typeof t)return window.dispatchEvent(new CustomEvent("lprequeststart",{detail:{data:t,requestID:++o}})),o}catch(t){}},s=function(t){try{window.dispatchEvent(new CustomEvent("lprequestend",{detail:t}))}catch(t){}};"undefined"!=typeof XMLHttpRequest&&XMLHttpRequest.prototype&&XMLHttpRequest.prototype.send&&(XMLHttpRequest.prototype.send=u(XMLHttpRequest.prototype.send,(n=XMLHttpRequest.prototype.send,function(t){var e=this,o=r(t);return o&&e.addEventListener("loadend",function(){s({requestID:o,statusCode:e.status})}),n.apply(e,arguments)}))),"function"==typeof fetch&&(fetch=u(fetch,(e=fetch,function(t,n){var o=r(n),u=e.apply(this,arguments);if(o){var c=function(t){s({requestID:o,statusCode:t&&t.status})};u.then(c).catch(c)}return u})));var c=function(t){return u(t,function(){try{this.dispatchEvent(new CustomEvent("lpsubmit"))}catch(t){}return t.apply(this,arguments)})},i=function(){if(document&&document.forms&&document.forms.length>0)for(var t=0;t<document.forms.length;++t)document.forms[t].submit=c(document.forms[t].submit)};document&&"interactive"===document.readyState||"complete"===document.readyState?i():window.addEventListener("DOMContentLoaded",i,!0),Document.prototype.createElement=u(Document.prototype.createElement,(t=Document.prototype.createElement,function(){var e=t.apply(this,arguments);return e&&"FORM"===e.nodeName&&e.submit&&(e.submit=c(e.submit)),e}))}}();.
Content Security Policy: The page’s settings blocked the loading of a resource at https://ajax.cloudflare.com/cdn-cgi/scripts/a2bd7673/cloudflare-static/rocket-loader.min.js (“script-src”).

I’m not sure why it’s having an issue with Cloudflare though, as it’s using the same DNS settings as my previous setup.


(Rafael dos Santos Silva) #4

On the DNS settings for this new site, is the cloud icon orange or gray? We recommend turning it gray to rule out any proxy interference. After changing it, you will need to wait a bit and try again.


(Alex) #5

I was able to get it resolved after greying out Cloudflare’s proxy option and then switching the SSL cert over from them to another provider. Thanks for the help.