Getting "permission denied" on new VPS install

So, I am switching VPS servers. Before getting rid of the one VPS, I downloaded the whole “discourse” folder from /var/discourse and put it on my Windows machine. I then got new Ubuntu VPS, installed Docker & Git, and instead of cloning Discourse, I just transferred my discourse folder that I already had from the old VPS onto it.

Now, when I run sudo ./launcher rebuild app, I get “permission denied.” I then back-tracked and tried to run ./discourse-setup but I get '/var/discourse' already exists and is not an empty directory. since I moved my fully-functional discourse folder there already. Why am I being denied, though? And yes, I ran the chmod 700 containers command too.

Hello :wave:

This is the right way to move Discourse to other server.


I wound up doing it with the CLI commands before you replied to this, but really weird how you can’t just drag-and-drop the old Discourse folder right to the new VPS, haha. Thanks anyway! I wound up deleting the Discourse folder from the new VPS and just did the ./discourse-setup setup again and then followed the CLI restore tutorial.

Hmmm, seems my forums URL works but not my direct URL now…