Google "no-reply" user pending approval


(Alex Armstrong) #1

I have a “Google” user with an email of no-reply@accounts.google.com pending approval.

I’m not sure why this came about. We use Google Apps to handle in-bound email. The email address I’m using for replies connect-replies+%{reply_key}@example.com. My notification email is connect-noreply@example.com, which doesn’t actually exist.

Ideas?


(Alex Armstrong) #2

Hmm. I just realised that I didn’t have Less secure apps option in Gmail enabled for the connect-replies@example.com account. Might this be the root cause?


(Felix Freiberger) #3

Is this account staged? Does it have posts?

I think Google sent you a notification mail for something, which cased a staged account to be created.


(Alex Armstrong) #4

It seem so, but it’s not something I set up:

I don’t know if you saw my second post. I think Gmail may have replied to the email because it rejected the signup from Discourse, because it wasn’t secure enough. I’ll delete this account in Discourse now that I have allowed Less secure apps to sign in to that Google Apps account. And see how it goes.


(Alex Armstrong) #5

Nope, it wasn’t that. The account re-appeared after I deleted it.But I’m pretty sure it’s related. No sure how, though.


(Felix Freiberger) #6

Does the account have any posts? If so, they should give you the reason why Google mailed you. If not, the rejection should have been logged in /admin/email/rejected – click on the error message to see the message that was received.


(Alex Armstrong) #7

Thank you! It was logged. I had changed the name of the account and it was polled while I was doing that, creating an error. Deleted the account again. Hopefully that’s the end of that.


(Felix Freiberger) #8

Great – so give a :thumbsup: to @zogstrip who implemented this log just this Monday :wink:


(Alex Armstrong) #9

Incidentally, I’m pretty sure that this issue is caused by this setting:

But I don’t understand enough about it to turn it off.


(Régis Hanol) #10

You probably got an email that was sent to and/or from no-reply@accounts.google.com and a staged user was created when Discourse processed that email.


Prevent creation of staged user for emails with auto-xyz header
(Alex Armstrong) #11

Yes. I was confused about what “staged users” actually are. But you answer that question very thoroughly here:


(Régis Hanol) #12