Guest Gate Theme Component

This works really well. Thank you.

I’ve made some minor edits to make the first post easier to read. There was one sentence I couldn’t understand at all, though:

custom url enabled
Add custom url to Login and Signup buttons / links by default this is redirect the visitor after click the Login or Signup button to the homepage and open Login or Signup modal. Note: If you leave unchecked this than the visitor left on topic page after click the buttons and the Guest Gate modal changes with Login or Signup modal which is dismissable so the visitor can close it and read the topic.

2 Likes

Thank you Jonathan :slightly_smiling_face: I really appreciate it :heart: Unfortunately my english is not the best :confused: Sorry for this! I will change these in the Theme Component or of course you could send a PR too. :slightly_smiling_face:

The custom url enabled site setting means.
You can add custom urls to the Guest Gate Login and Signup buttons/links which by default use these custom urls /login and /signup these redirect the visitor to the homepage and open the Login or Signup modal. So if you checked it, it will activate the two settings below this. The custom login url and custom signup url.

If you leave this setting unchecked then it will keep the visitor on topic page after click the Guest Gate Login or Signup buttons/links and open the Login or Signup modal on the same topic page. After this the visitor can close the modal.

I hope it helps to understand and again thank you for your time to makes it more understandable :slightly_smiling_face:

2 Likes

Your English is fine, and there’s nothing wrong with your JavaScript, which is the important thing :slight_smile: What about this?

  1. custom url enabled – Enable the custom login url and custom signup url options. The normal behaviour (if you leave this option unchecked) is for the Login or Sign Up modal to appear on the current topic page.
  2. custom login url – For example, /login is the home page with the “Login” modal displayed.
  3. custom signup url – For example, /signup is the home page with the “Sign Up” modal displayed.
2 Likes

That mostly thanks to the plugin authors and contributors too. But I do my best to develop this and add more features, fixes etc. :slightly_smiling_face:


Thanks for the correction :slightly_smiling_face: that seems much better. I will correct these in the theme component too.

Hey all,
I recently installed this component and it works like a charm but I am not sure if the gating mechanism slows down the google bot from crawling the topics.

Does anyone know about the impact on crawlers?

2 Likes

I am having some configuration issues with Guest Gate when I am using SSO with Discourse Connect.

The user is able to login in the main site and then appears to be logged in Discourse but after clicking a few topics the guest gate modal shows up. This is unusual as the user is logged in.

I have custom URLs for login so when user clicks on I am already logged in they are taken based custom login page and the cycle repeats itself.

Only way around this is when user clicks on the native login button in Discourse and is automatically logged in.

It appears that for some reason Guest Gate is not honoring the login from SSO and requires native login to activate.

Have other people faced this issues? Any suggestion on a solution or a workaround?

1 Like

I’ve slid your support question over to the component topic itself to try and get the proper eyes on it. :+1: Hopefully @dodesz can suggest something? :crossed_fingers:

3 Likes

Hello @Himanshu_Singh :slightly_smiling_face: Thanks for the report I will look into this.

3 Likes

Thanks Don. I appreciate it! I had another inquiry for earlier :point_up: Any thoughts on this question?

2 Likes

The Guest Gate is not showing up for crawlers such as GoogleBot. So it shouldn’t cause any slow or issue with crawling.

4 Likes

Hello,

I checked it with Discourse Connect and works as expected for me. The modal not appears after I logged in. Can you share your guest gate settings (screenshot) and your website url (here or PM) to I can check this? :slightly_smiling_face:

If you use Discourse Connect you have to disable custom url enabled checkbox. Because it will first try to redirect to the custom urls after clicking the Guest Gate modal login / register button. If you leave this checkbox unchecked than the buttons will use the Discourse Connect url.

2 Likes

Here is the GIF that shows the issue (the user is not logged in after SSO login) - Screen capture - c6935b85cf70cf6b0aee72e6a82a3164 - Gyazo

Here are the guest gate settings: Screen capture - 1dd428ada77c70f84e49c81dbd30fe69 - Gyazo

Community URL - https://community.showprowess.com
Website URL - https://www.showprowess.com

Thanks for looking into this Don!

1 Like

Thanks @Himanshu_Singh,

I think it is because you using custom urls on guest gate buttons https://www.showprowess.com/login and https://www.showprowess.com/register which is not same as SSO login. Please uncheck the custom url enabled setting in guest gate and try again. :slightly_smiling_face: If you uncheck this the guest gate modal buttons will use Discourse Connect.

Screenshot 2022-06-30 at 22.42.53

1 Like

So I unchecked the box - Screenshot - 50b6ee19e5e09edd5cee337f329be7a5 - Gyazo

But still the user is not automatically logged in from WordPress. Now both the buttons direct to /login page which is the Discourse Connect link for the site.

Hello,

I pushed an update for Discourse Connect usage.

This update removes signup button when Discourse Connect enabled and only show a Log In button. I also added different text to Discourse Connect login button guest_gate.sso_log_in . Which you can find under theme translations, the default text Log In . This update also add a custom text guest_gate.or default or separator which appears between login and signup links. Only appear when you use links and not buttons.


And now add another update to the component.

This update will add icon to Log In and Sign Up buttons. I also add some settings to change icons.


3 Likes

Thanks Don! After this update my Sign Up button disappeared, any idea why?

1 Like

Memberful is also use Discourse Connect? Can you check that? Thanks :slightly_smiling_face:

Yes it does use Connect

1 Like

I see now on your site the Join NPN button on header is custom button and the Sign In button use Discourse Connect. Guest Gate modal works as expected because you use Discourse Connect login so the signup button is not appear by default. It is hard because users who use Connect cannot use guest gate custom urls settings for authenticate login because that url is mostly generated. But it seems to Memberful login url is not contains generated section.

I think we should make separate settings for Discourse Connect usage. :thinking: I will add a setting to add sign up button to Discourse Connect.

2 Likes

@Himanshu_Singh and @davidkingham I pushed an update to Discourse Connect signup button.

It will add a settings and translation to Discourse Connect logins. You can disable the custom url enable section and check the enable discourse connect signup checkbox then paste the signup url in discourse connect signup url what you use in custom signup url.

Theme Settings
Screenshot 2022-07-05 at 17.47.14

Theme Translations
Screenshot 2022-07-05 at 17.47.42

3 Likes