Header submenus

Would you happen to know how to move it down into the main nav bar, so there’s no extra top bar?

2 Likes

It’s doable via css but not really clean. You could try this theme component instead

1 Like

It’s worked with a hard refresh, all’s good now, thanks =]

1 Like

Yeah, not near as clean. Thanks, though. Hope this becomes a feature.

Hi folks,

still a few things to do in administering new and existing entries, but overall a very very handy component.
What I´d be interested in is, how to push the configuration from a test environment to production when everything is set up ?
Is there a best-practice how to do that ?
I tried to export the component and import it again afterwards, but it seems to get imported with default settings.

Or did I do anything wrong ?

Thanks and greetings!

Cheers,

Wurzelseppi

Hi - this theme component works well. However is there a way to edit the menu items without having to redo a lot of data entry each time? I do not see any way to change the order of items nor any way to edit an individual item except to delete it and add a new item at the bottom of the list. Am I missing something?

1 Like

Hi does this work with this version Installed v2.3.0.beta7 +7?

I tried but can’t see it in the configs via the GUI. This is the part from my app.yml

## see https://meta.discourse.org/t/19157 for details 
hooks:
  after_code:
    - exec:
        cd: $home/plugins
        cmd:
          - git clone https://github.com/discourse/docker_manager.git
          - git clone https://github.com/iunctis/discourse-formatting-toolbar.git
          - git clone https://github.com/discourse/discourse-push-notifications.git
          - git clone https://github.com/discourse/discourse-akismet.git
          - git clone https://github.com/discourse/discourse-voting.git
          - git clone https://github.com/discourse/discourse-adplugin.git
          - git clone https://github.com/discourse/discourse-data-explorer.git
          **- git clone https://github.com/discourse/discourse-header-submenus.git**
:thinking:

The theme components have a different installation, you have to go to the customize section of your forum yourforum/admin/customize/themes and use the Install button

Install from a git repository and use this link : GitHub - discourse/discourse-header-submenus

2 Likes

Ooow it’s a component!
I thought it was a plugin😳
Thanks

1 Like

The preview page at Discourse Theme Creator looks good on my desktop, but on my Samsung S9 the header is compressed to the left, and all the text is much compressed/smaller than normal. Other Discourse forums including meta.discourse.org look normal.

Try another theme and see

Hi there!

Awesome component - was wondering, though, is there any way to re-order the submenu items within the drop-down? I’m using several groups of submenu items per menu item split by dividers, and it seems that in order to add a new submenu item, for example, in between two pre-existing submenu items further up the list, I have to delete everything after the new submenu item and then re-do it in the correct order, with the new item added. Is there some sort of “move” mode I’m missing?

1 Like

Hey guys,

just wanted to ask if anyone know, where this plugin keeps its data ?
I want to maintain the links in an normal editor or something, because the UI for maintaining them is a bit … ahhh… unfinished … in my opinion …
Things I´m missing or that are wierd to use, are

  • Edit existing entries
  • Reorder entries

Is there by chance a way to edit them somewhere else ?

Thanks and greetings,

Wurzelseppi

You could fork it on github and edit it there.

Thanks for answering so quickly @pfaffman!

But I didn´t mean to change something in the theme, but just wanted to find the files where the entries are stored.
That way I could, perhaps, edit the links over vi or something.
At the moment, as is also stated here

you have to for example delete an entry to change it, and then it´s at the bottom, and no more at the spot it was originally.

1 Like

Hi there,

I´m confused. I did a text search in the whole docker container for a file which contains a text from my link.

grep -Rln “–link text–” > grep_result.txt

took awhile, but worked.
Result:

tmp/javascript-cache/9472eeea33e85a8833e1fb8b2d6f9804965da582.js
tmp/stylesheet-cache/mobile_theme_4_bc0b3c3882d1e3c2da47e43a873a25f24bf6b565.css.map
tmp/stylesheet-cache/desktop_theme_4_967c20dfece2ee302ae64351e7f972504cb863d7.css.map

… means just caches.
Then I did a pg_dump of the whole database and searched within that dump also for that text.
The only spots I found is once again cache and history tables

public.stylesheet_cache
public.javascript_caches
public.user_histories

Hmmmmm… did I miss something ?

still walking in the darkness :frowning: … nobody can help here ?

@Wurzelseppi the default values are stored in the theme’s settings.yml file. If you make changes to the defaults, then those changes are stored in the database, in the theme_settings table.

For now, your best bet for reordering items is to copy/paste them between the rows, these UI elements currently don’t support drag-and-drop.

5 Likes

I think this component is screwing with the emoji selector?

Is there a chance that the UI gets improved?
I find that component very useful, but the maintenance of the links is somehow complicated :slight_smile: