Help us build the new 2.0 Dashboard


(Joffrey Jaffeux) #275

I don’t know, given what you show to me, you don’t seem to have any data on this instance. So it’s expected ? I can’t reproduce any of this in any of the instances I can try it.

Also you seem to have some js/css cache issue. Some of the styles I see on this page are not what they should be.

Concerning the last backup which seems incorrect for you, can you enter a rails console and do: Backup.all please ?

root@my-discourse:/var/discourse# ./launcher enter web_only

WARNING: We are about to start downloading the Discourse base image
This process may take anywhere between a few minutes to an hour, depending on your network speed

Please be patient

Unable to find image 'discourse/base:2.0.20180802' locally
2.0.20180802: Pulling from discourse/base
8ee29e426c26: Pulling fs layer
6e83b260b73b: Pulling fs layer
e26b65fd1143: Pulling fs layer
40dca07f8222: Pulling fs layer
b420ae9e10b3: Pulling fs layer
b89ccfe9dadc: Pulling fs layer
40dca07f8222: Waiting
b420ae9e10b3: Waiting
b89ccfe9dadc: Waiting
6e83b260b73b: Verifying Checksum
6e83b260b73b: Download complete
e26b65fd1143: Verifying Checksum
e26b65fd1143: Download complete
40dca07f8222: Verifying Checksum
40dca07f8222: Download complete
b420ae9e10b3: Verifying Checksum
b420ae9e10b3: Download complete
8ee29e426c26: Verifying Checksum
8ee29e426c26: Download complete
8ee29e426c26: Pull complete
6e83b260b73b: Pull complete
e26b65fd1143: Pull complete
40dca07f8222: Pull complete
b420ae9e10b3: Pull complete
b89ccfe9dadc: Verifying Checksum
b89ccfe9dadc: Download complete

fdsfsb89ccfe9dadc: Pull complete
Digest: sha256:be738714169c78e371f93bfa1079f750475b0910567d4f86fa50d6e66910b656
Status: Downloaded newer image for discourse/base:2.0.20180802
root@my-discourse-web-only:/var/www/discourse# Backup.all
bash: Backup.all: command not found
root@my-discourse-web-only:/var/www/discourse# rails c
/var/www/discourse/lib/discourse.rb:203: warning: already initialized constant Discourse::BUILTIN_AUTH
lib/discourse.rb:203: warning: previous definition of BUILTIN_AUTH was here
[1] pry(main)> Backup.all
=> [#<Backup:0x00005631920aee60

(Joffrey Jaffeux) #277

So it’s probably right then, I don’t know your timezone, but the filename is done with server timer. The time you see in the dashboard, is file ctime converted to UTC and then shown in your timezone.


Unfortunately though i rebuilt both data and web_only containers about 30 minutes ago, the dashboard’s backup time still doesn’t refresh properly :(.

How to figure out from where the caching problem happens? Do you have any tips/ topics i should follow to fix my setup?

I do use cloudflare, but for my discourse subdomain, the DNS caching is off (i mean that orange cloud in this image, for me it is off=gray)

(Pad Pors) #279

after a recent update, data are not shown individually anymore in Persian locale. this is what I get when I click on sign ups, topics, posts, …:

it’s resolved if I change the locale to English.

the error in reports panel:

ArgumentError (invalid date) /var/www/discourse/vendor/bundle/ruby/2.5.0/gems/activesupport-5.2.0/lib/active_support/core_ext/string/conversions.rb:47:inparse’`

error log.txt (17.5 KB)

(Joffrey Jaffeux) #280

Yes I fixed it last week with a lot of other things related to the locale you use. I wasn’t aware of this but we are passing dates in query param using your locale, and back and forth conversions were not handled correctly. I was holding releasing it on master for internal reasons, but should be released in the week coming.

(Makary Gołosz) #281

Does it not show exact number when you hover cursor above it?

(Travis) #282

Not for me it doesn’t.

(Jeremy M) #283

In the Daily Engaged User report, when you select it to drill down to custom dates, is the number the total number as counted daily engaged users, and not the actual total number (i.e. “Monthly Engaged Users”)? Or is that the total count of distinct users thus bringing about the average displayed on the dashboard?

(Jeff Atwood) #284

I think this should be closed for now as this iteration of dashboard is complete (shipped in 2.0, some enhancement for 2.1).

(Jeff Atwood) #285

(Joffrey Jaffeux) #286

A quick note. Thanks to a cool suggestion of @eviltrout charts will now use tertiary color:

(Robin Ward) #287

Love this! Looks great.


@joffreyjaffeux there is no indication of what the dotted lines mean in the graphs.

(Daniela) #289

It is the previous trend, still experimental feature enabled only for some graph, which will serve to evaluate the long-term trend (annual).

(Joffrey Jaffeux) #290

Yes I will work on this more post 2.2 release, it’s kind of experimental at the moment. My feeling so far is: works great for yearly view, not so much for everything else.

Also I kept it active as I wanted to see how it was going to be displayed on real life data. I don’t feel like it’s so annoying it should be removed until we settle on something definitive.


I shoulda said that I know what it is and that it’s experimental but that for new users we should prob put in a tooltip or something so that it at least makes sense. :slight_smile:

But not urgent. Let’s roll with 2.2