HEVC images and error message Discourse::InvalidAccess

Hello all,

I tried to upload some images into a post and always got the message Discourse::InvalidAccess.

When I looked closer, I noticed that the JPG files use the HEVC compression. Then I remembered that I made the photos with an iPhone and edited the photos before sending them out via email.
Uploading the photos after resaving them as JPG file on Windows worked. So it has to be something with the HEVC compression. Maybe the file extension .jpeg which Apple Mail chose is not okay, too?

Anyway, the error message is not user friendly when it comes to “normal” users. Is there a way to change that?

Also, is it possible to support HEVC in Discourse?


Images with HEVC compression already work in Discourse, they are converted to JPG in the backend. But those should be properly identified with the .heif extension.

AFAIK having HEVC compression in a JPG container is not valid.

Can you try to take a picture from your phone in HEVC and upload it directly here?

That’s interesing, thank you!

I could rename on of those photos I mentioned and try to upload with .heif extension? Would that be useful (first)?

Images that have been manipulated and transformed by one of more programs may just be invalid. I suggest taking a picture with your phone and trying to upload that, which is the flow that is common for most users.

Well, but that is the typical usecase. :wink: So it should work in my eyes.

I will try. Later. The iPhone is at home.

And I will also try to edit a photo and upload it. It is also interesting for me to know where the problem comes from.

But as I said, it is not something total uncommon what happened here… Starting with never altering the file extension, as everything happened on the iPhone.

Test, photo from iPhone

1 Like

One of the photos I talked about in my first post, renamed as .heic:

If I try to upload it as .jpeg I get:


Interesting. And a different message than what I got in my own forum. And because the photo with the USB sticks is also HEVC/HEIC, but uploaded as IMG_1018.jpg (I was able to see this when it was uploaded).

Something is strange here…