How to allow users to post right away with no roadblocks


(Leah Kramer) #1

Hi all. What settings do you set to allow users to post right away with no moderation/approval etc neeed?

Our forum involves become a paid member via our main site and then you get access to the forum via SSO. We really want to encourage members to introduce themselves right away. And since they’ve paid to become members, there’s not much risk them being spammers.

(I’m sure this is answered somewhere in this forum but I couldn’t find the right search phrase apparently.)

Thx!


What are the conditions that cause a user post to require approval? I want to turn this off
(Joshua Rosenfeld) #2

If you truly, 100%, no conditions trust users who access your site, you can increase the default trust level from 0 to 1. That should help eliminate some of the roadblocks like limited links, uploads, spam checks, etc. Note that they’ll still be limited in the total number of topics and posts they can create in the first 24 hours, but not starting at TL0 will help.

Important Note for others reading this later: Unless you 100% trust your users (like a paid site via SSO), don’t change the default trust level - you’ll be opening yourself up to tons of spam.


What are the conditions that cause a user post to require approval? I want to turn this off
(Leah Kramer) #3

Thanks for the reply! Your warning has given me some more to think about. I wouldn’t want to open the floodgates to spam inadvertently. Even though this is a paid access forum, we all know that spammers will always find a way.

What I’m hoping to achieve is that when a brand new user joins and wants to ask a question right off the bat or introduce themself, I’d like the message to go through right away unless there’s very good reason for it not to go through.

I have all these set to 0 and yet we currently do occasionally have to approve a post/topic by a new user.

  • approve post count
  • approve unless trust level
  • approve new topics unless trust level

So I wonder what it is that’s causing us to sometimes have to approve new users posts/topics.


(Sam Saffron) #4

That is likely our fast typer test, try setting “min first post typing time” to 0.


(Leah Kramer) #5

I’ll try that. Thanks for the tip.

This thread has helped me pore over and understand the settings better. They are daunting at first. So thank you!


(Leah Kramer) #6

One more question related to spam – For one of the Discourse forums I maintain, the “mailing list mode” is really popular since the community used to be a big listserv. So if a spammer signed up and posted some offensive stuff, their posts would go out to everyone as emails. Does Discourse have a way of making it so that only TL(n) users posts will go out as emails? I didn’t see a setting for this but figured I’d ask.


(Geoffrey Challen) #7

Sorry to reopen this, but we’re having the same problem. I have default trust set to 1 and min typing set to 0 and we are still seeing posts held for approval at times. Frustratingly, there is no reason indicated when this happens.

Any clues? Discourse has so many settings that I suspect I’ve missed something…


(Mittineague) #8

If you go to Admin -> Logs -> Staff Actions are those posts

blocked_by_staff: ‘Account blocked’ New user typed too fast


(Geoffrey Challen) #9

I see nothing useful there. The last log is related to a setting I changed (turning off anonymous access). Thanks for the pointer though!


(Joshua Rosenfeld) #10

What are the values of the following settings?
approve post count
approve unless trust level
approve new topics unless trust level