How to avoid redirecting from "https" to "http"

My discourse docker(Recent version) is deployed on a single server(centOS) and uses a ‘80:3000’ configuration, followed by separate use of nginx to provide HTTPS services.

Users can access it normally “” . But after logging in, the redirect address changed to “” (starts with http). The link in the activation email for new users also starts with http.
The above situation will prevent users from further accessing the website.

:star:What configuration should I modify to make the jump link, redirect address, and email activation link on the page start with https?

Looking forward to answering. Thank you in advance :hibiscus:.

Enabling the force https site setting should fix this.