How to create a new user in pure sql

What are the minimum required tables that require rows to be added to create user, so is then visible active in discourse

Ive just inserted one row into user_emails

insert into user_emails (user_id, email, "primary", created_at, updated_at) values (2,'user@email.com',true, now(), now());

Unsuprisingly has not appeared in the gui, but what are the minimum steps, do I need to add to some more tables, or is there some restart I need to do.

Now I expect someone will say this is not the right ways to do things, and I understand that, but for me it might be as I’ll explain below (some of my assumptions may be incorrect but this is my understanding)

  • All the import scripts that import from another database based forum expect to be able to connect to the other forum from the discourse instance. But being able to access the other forum (jforum) from live discourse instance is going to be difficult if not impossible, similarly trying to install a discourse dev environment where by old forum resides (very old server) is also not possible.
  • I dont understand Ruby on Rails so I cant modify the existing scripts, but I do understand SQL
  • I could use the API (I only have 5000 users) but I want to be able to plugin/method that keep the md5 password hash rather than requiring all users to reset their passwords so I don’t think I can do this using the API
  • There is a jforum import script so I can use that to look at the SQL required to get data out of jforum no problem to then put into csv files to load into database.
  • The bulk importers possibly provide the way to add SQL into discourse but struggling to see the SQL.
  • Seems getting the users in is the key thing, then adding categories, topics and posts should not be so hard.

Right!

If you did, you’d not be asking. :wink:

The likelihood that you’ll end up with a corrupt database is pretty high. And then no one will be able to help you.

Dump your database and restore on your local Discourse server (or anywhere that it can connect to–I’ve done larger imports with a remote database over my home internet connection) and then run the existing script.

It’ll be much easier to use Ruby that you don’t understand than to understand it well enough to figure out how to write the SQL. I learned Ruby a long time after I wrote my first importer.

5 Likes

That is a bit condesensing !
If the bulk import script is running sql (as I think it is)then documenting the SQL required to create a user is really no more dangerous then trying to use a bulk import script. And since I currently have a vanilla discourse install it wouldn’t terribly matter it if got messed up.I expect I have many more years in development than yourself.

What I don’t have great experience is all the admin tasks, and my first attempt to install a local Discourse server just opened a can of worms, and if I cant connect to my JForum mysql server from my discourse server then I’m going to have to install mysql as well and transfer the database. The existing jforum script isn’t checked into the main source tree, and Im on a very old version of jforum so not expecting it to work.

2 Likes

I meant no offense. I guess you missed the :wink:?

I bet you’re right!

Sometimes free advice from someone that’s worked with Discourse full time for over three years, has done scores of imports, and written several importers from scratch is worth what you pay for it.

5 Likes

How about setting up an SSH tunnel?

Inconsistent, maybe. Corrupt, no.

But you can create the users using the API and then insert the md5 hashes in a custom field using SQL. You will have best of both worlds.

5 Likes

Ooh! That’s a pretty great idea.

This is the free advice you’re looking for!

3 Likes

Yes, I had the thought but as I dont quite understand how the md5 hashing works wasn’t clear if that was possibility, okay I will give that a go.

All you need to do is insert a custom field:

  • user_id: obvious
  • name: “import_pass”
  • value: the md5 digest

And install the migratepassword plugin.

2 Likes

Thanks, have a few questions I hope you can help me with.

Installation

Run bundle exec rake plugin:install repo=http://github.com/discoursehosting/discourse-migratepassword in your discourse directory
Restart Discourse
  1. I have installed it, but how do I restart Discourse ?

  2. How do I insert the custom field, can you give the SQL, or it can it be done with the api with the "user_fields[1]": "string" part. I am now programmatically able to create user via api but Im currently ignoring this field.

  3. If you have the plugin installed, is the value of password passed as part of api creat user call irrelevant.

  1. no, it will prevail over the md5 digest in the custom field.

The answers to the other two questions can easily be found on this forum. If you want to save time we can do the import and/or hosting for you as a paid service.

1 Like

I did search for both answers, was unable to find. In the first case it is confusing that some installs are done via editing the yaml file and then relaunching the docker , and some seem such as this are installed whilst in the docker container, its not cxlear what restart means in this case.

I cant really find any pure sql in this forum

Surprised there seems such a push to sale paid services for using this opensrc software , never like this when i ask questions on stackoverflow.

1 Like

I love to think along, innovate and contribute. But I also need to make a living and that means that I need to draw a line somewhere, and I try to draw it where I get the idea that I’m doing work instead of innovating, contributing and thinking along.

Looking up the SQL query for a user custom field is work for me, and as you’re an experienced dev I estimate that you can figure it out as well :smiley:

4 Likes

Well sure I can try and work it out but no harm in asking since its not

can easily be found on this forum

As for the other question, well it remains unclear to me.

I dont expect you to do my work for me, on the other hand side i do genrally find it frustrating how documentation assumes alot from users.

OK question 2, an example of adding a custom import_pass field for user_id 5, (user_id can be seen in the user_emails table or id from users table)

insert into user_custom_fields (user_id, name, value, created_at, updated_at) values (5,‘import_pass’,‘2aee1c40222c7754d4534e61452612cc’, now(), now());

2 Likes

Okay I found it
./launcher restart app
but doesnt seem to be restarting, I can enter app and connect to db, but cant connect to website. May just rebuild and start again

1 Like

So I ran ./launcher rebuild app and now it is back and working.

I thought this would recreate the database but it has not so I guess that is because the actual database is persisting outside of docker and rebuild just rebuilds the docker app. Also I see the dataexplorer plugin I added (by modifying the yaml file is still there). But is the passwordmigration plugin there or does it get wiped out by rebuild, there is certainly nothing in the plugs in section of the adminpage.

Right I tried installing passwordmigration and then ran restart again, and once again my site is down, it does seem like passwordmigration is breaking something ?

So rebuilt again, got it working (but now passwordmigration plugin missing). If I run ./launcher restart app without installing migrationpassword first it restarts okay, so does seem to be a particular problem with migrationpassword on my setup

1 Like

Last time I tried, the passwordmigration plugin was incompatible with running an import, so you’ll want to install it after you do the import.

It could be that it’s breaking your rebuild, but that’d be fairly surprising, as Richard uses it in his hosting. I recommend that you install it in app.yml just as you did the data explorer after you’ve done your import.

rm -rf the postgres directories in /var/discourse/shared/standalone if you want to get a new database. Maybe have a look at Advanced Troubleshooting with Docker

2 Likes

disabling it during the import should be sufficient

3 Likes

Weird, dropped database and ran ./discourse-setup so had a brand new install, everything fine.
Installed migrationpassword with rake and restarted, again website fails with 502 !
DataExplorer plugin still existed, so removed that, rebuilt, ok, then reinstalled migrationpassword and fails with 502 again.

So confusing because clearly works for others but doesn’t work on my vanilla install.

Will try to install via editing the app.yml file next.

1 Like

(Xmas shopping got in the way) but I have at last tried installing migratepassword by editing app.yml and rebuilding and … it worked !
But the bundle exec rake plugin:install repo=http://github.com/discoursehosting/discourse-migratepassword option does not work on my vanilla install, maybe this needs checking/removing in the GitHub - discoursehosting/discourse-migratepassword: Support migrated password hashes README.md

1 Like