How to disable wizard at startup?

Hi all,

I have migrated my discourse app from one server to another. I could made the restore by command line.

But when I go to my site, I still have the wizard : this blocks to automate by script any move on another server.

I couldn’t find any information on how to disable the initial wizard. I don’t need to create any temporary admin since the restore has been done (including, I suppose, all the users in the database).

Thanks !

You can restore from the command line.

  ./launcher enter app 
  discourse restore

In fact, I still see the wirazd maybe because the restore process failed.
The [quote]./script/discourse restore xxx.tar.gz[/quote] ends with :

I removed all the folder “standalone” and retried, same result.

I have made a big copy/paste of the “standalone” folder. It worked, but I lost the icons at the top of the website, even if I redefine them in admin parameters.
Maybe that’s happening in /exec/shared/standalone/uploads/default/original/1X (which is correctly full).
I am trying to understand how to make a move from one server to another when “restore” fails.

The wizard goes away if there is an admin user, but it seems to have nothing to do with what you’re trying to solve.

If your seeing that postgres permissions error then you have some other problem. If you delete the postgres directory then you have to rebuild for it to recreate the stuff that postgres needs.

The command line restore is what I most often do when moving to another server. I did it Friday to move a server that was running 1. 6.0-beta1 and it worked.

Another easy to do it is to rsync the entire /var/discourse directory (excluding logs and some other stuff if they are big). With that method I always stop the container before doing the rsync. Pulling over the letsencript and ssl folders keeps you from hang to rebuild to get new certs.