How to resolve the warning message?


#1

The ./launcher logs app shows warnings:

  1. 42:M 26 Nov 09:22:44.646 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.

  2. rsyslogd: invalid or yet-unknown config file command ‘KLogPermitNonKernelFacility’ - have you forgotten to load a module? [try http://www.rsyslog.com/e/3003 ]
    rsyslogd: warning: ~ action is deprecated, consider using the ‘stop’ statement instead [try http://www.rsyslog.com/e/2307 ]
    rsyslogd: Could no open output pipe ‘/dev/xconsole’: No such file or directory [try http://www.rsyslog.com/e/2039 ]
    Server listening on 0.0.0.0 port 22.

  3. nginx: [warn] invalid parameter “spdy”: ngx_http_spdy_module was superseded by ngx_http_v2_module in /etc/nginx/conf.d/discourse.conf:38
    nginx: [warn] invalid directive “spdy_keepalive_timeout”: ngx_http_spdy_module was superseded by ngx_http_v2_module in /etc/nginx/conf.d/discourse.conf:39
    nginx: [warn] invalid directive “spdy_headers_comp”: ngx_http_spdy_module was superseded by ngx_http_v2_module in /etc/nginx/conf.d/discourse.conf:55

  4. fail: nginx: runsv not running

  5. fail: unicorn: runsv not running

  6. fail: redis: runsv not running

  7. fail: postgres: runsv not running

  8. fail: sshd: runsv not running

Warning 1: I have add net.core.somaxconn = 1024 to /etc/sysctl.conf

and cat /proc/sys/net/core/somaxconn is 1024, even after reboot the value is 1024

but after ./launcher rebuild app, logs still shows this warning.

rsyslogd warning, what does that mean?

nginx spdy warning, why?

Thanks.


#2

Maybe docker can’t read host’s configure setting. The redis server in the docker may be related to this.

When you ./launcher enter app into the container, the somaxconn is still not changed.

cat /proc/sys/net/core/somaxconn

the value is 128.

How to change the value in the container ?

Or the container can read hosts’ /proc/sys settings?

PS.

I mount container’s /proc in a writable directory, so we can edit the kernel value from 128 to 1024 or higher. But when rebuild docker or reboot the host system, the somaxconn was reset to 128. Problem reoccurs.

Maybe it is the docker’s problem.


(Discourse.PRO) #3

I have found the solution:

./launcher rebuild <container> --docker-args "--sysctl net.core.somaxconn=65535"

«docker run» → «Configure namespaced kernel parameters (sysctls) at runtime»