How to setup "Reply by email address" now that it must be different from the "Notification email"

Looks like a recent update: I no longer can set the reply by email address setting same as the notification email.

Please help me understand how to setup those two settings.

The following setup is not working:

  1. notification email is set to (same as SMTP username)
  2. reply by email address is set to forum+%{reply_key}

Now, when I try and send a test email from /admin/email, my SMTP server rejects with the error:

Sender address rejected: not owned by user

Looks like it tries to use From = forum+...@ while authorizing with robot@

smtpd[3683]: connect from[]
smtpd[3683]: NOQUEUE: reject: RCPT from[]: 553 5.7.1 <>: Sender address rejected: not owned by user; from=<> to=<> proto=ESMTP helo=<localhost.localdomain>

Same issue when signing up a new user.

With the new requirement, how do I setup both values?

I’d assume you’re using your own SMTP instead of something like mailgun?
I’ve seen this issue when I was trying to use my own mail server to send (and receive) emails for discourse.

Solution is to allow the SMTP user to send email from wildcard address and this will get fixed.

What’s currently happening is that is trying to send an email which would get a reply-to address to enable reply by email. your pattern is to use forum+%{reply_key} which is different than robot+%{reply_key} this is the only reason that I see it’s failing and you can fix this by allowing robot to send on behalf of forum


Thanks @itsbhanusharma, just added an alias in my MailInABox setup, and it worked:

forum@... => robot@...

P.S. Your assumption was correct re using my own SMTP.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.