I got an error after updating my forked install

unsupported-install

(ひさし) #21

I did not upgrade postgres and something else.
I just want to upgrade discourse and did rebuild app


(ひさし) #22

I do not know the cause of this error, but the profile picture of the user whose profile image has not been set is no longer displayed like below :disappointed_relieved:


(ひさし) #23

I have not solved the problem that I can not upgrade yet.


(ひさし) #24

@Stephen @pfaffman

This is response from “./launcher rebuild app”.
Sharing with google docs due to limited number of characters
https://docs.google.com/document/d/1jNUU1XgC9ByIlm5XaT3aPgqWyN6LNHIqWiC_0Xbu3t0/edit?usp=sharing


(ひさし) #25

I tried it variously, but I can not solve it yet.

The topic has become redundant, so I will summarize it.

  • I installed Discourse following the official way.
  • The plugins I am introducing are discourse-adplugin and docker_manager.
  • The link below is response from “./launcher rebuild app”, after moving to “/var/discourse” and executing “git pull”.


Since the error sentence has been lengthened, I wrote it in google docs.
Please give me some advice…


(ひさし) #26

@pfaffman @Stephen
Do you have any ideas?


(Rafael dos Santos Silva) #27

Please run

git remote -v

And paste the output here.


(ひさし) #28

Thank you for your reply

root@bbs:/var/discourse# git remote -v
origin https://github.com/sudo/bbs_ytmura.git (fetch)
origin https://github.com/sudo/bbs_ytmura.git (push)

※“sudo” is a temporary name for githubID


(Rafael dos Santos Silva) #29

Why did you fork our discourse_docker repository!?

This isn’t an install that followed our Install Guide so there isn’t much we can do here.


(ひさし) #30

I intended to do so, but it does not seem to be done. I’m sorry.

Is it possible to change it now?

By the way, I was able to update until the previous time, but it seems I cannot do it from this time.


(Rafael dos Santos Silva) #31

It will be very hard to give any advice, since you didn’t follow the guide and didn’t give the real output of the git remote -v.


(ひさし) #32

I see … I seem to have cloned this on my private repository several months ago…

Do you think that there is a problem when updating the latest version of this to my private repository, and rebuild app?


(Rafael dos Santos Silva) #33

Stop pointing to a fork, and point to the official repo.


(ひさし) #34

Ok … but I can not find a way to update a private repository that I incorrectly cloned…


(Rafael dos Santos Silva) #35
git remote set-url origin https://github.com/discourse/discourse_docker.git
git pull
./launcher rebuild app

(ひさし) #36

That works!! Thank you so much @Falco :sob::sob::sob:


(Sam Saffron) #37